# CVE-2023-34102: Possible unsafe reflection / partial denial of service in avo

> Attackers can achieve remote code execution or cause application crashes in the Avo admin panel by manipulating polymorphic field inputs without backend validation.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2023
- **Updated:** 8 Jan 2025
- **Also known as:** GHSA-86h2-2g4g-29qx

## What is CVE-2023-34102?

CVE-2023-34102 is a high-severity code injection vulnerability in avo-hq avo, published on 5 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Avo is an open source ruby on rails admin panel creation framework. The polymorphic field type stores the classes to operate on when updating a record with user input, and does not validate them in the back end. This can lead to unexpected behavior, remote code execution, or application crashes when viewing a manipulated record. This issue has been addressed in commit `ec117882d` which is expected to be included in subsequent releases. Users are advised to limit access to untrusted users until a new release is made.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-34102?

4 open source packages ship an affected version, including avo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `avo` | RubyGems | All versions | 2.33.3 |
| `avo` | RubyGems | All versions | 2.33.3 |
| `avo` | RubyGems | From 3.0.0.pre1 to 3.0.0.pre12 | None |
| `avo` | RubyGems | From 3.0.0.pre1 to 3.0.0.pre12 | None |

Products: Avohq Avo.

## How do I fix CVE-2023-34102?

Upgrade avo to 2.33.3 or later.

## Is CVE-2023-34102 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34102 exists.

## Other vulnerabilities in avo-hq avo

- [CVE-2024-22191](https://insights.sbomify.com/CVE-2024-22191/): Stored cross-site scripting (XSS) in `key_value` field in Avo (high 7.3)
- [CVE-2023-34103](https://insights.sbomify.com/CVE-2023-34103/): Stored XSS (Cross Site Scripting) in html content based fields of avo (high 7.3)
- [CVE-2024-22411](https://insights.sbomify.com/CVE-2024-22411/): Cross site scripting in Action messages on Avo (medium 6.5)
- [CVE-2026-33209](https://insights.sbomify.com/CVE-2026-33209/): Avo has a XSS vulnerability on `return_to` param (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34102 and fix it if it is affected.

What it is: CVE-2023-34102 is a high-severity code injection vulnerability in avo-hq avo, published on 5 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34102 exists.

Affected packages and fixed versions:
- avo (RubyGems): affected all versions; fixed in 2.33.3
- avo (RubyGems): affected all versions; fixed in 2.33.3
- avo (RubyGems): affected from 3.0.0.pre1 up to 3.0.0.pre12; no fix listed
- avo (RubyGems): affected from 3.0.0.pre1 up to 3.0.0.pre12; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34102/ (Markdown: https://insights.sbomify.com/CVE-2023-34102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34102
- OSV: https://osv.dev/vulnerability/CVE-2023-34102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34102/
Summaries are generated and may contain mistakes; the official description above is the record.
