{"answers":{"affected":"4 open source packages ship an affected version, including avo. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34103 exists.","fix":"Upgrade avo to 2.33.3 or later.","what":"CVE-2023-34103 is a high-severity cross-site scripting vulnerability in avo-hq avo, published on 5 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-34103 and fix it if it is affected.\n\nWhat it is: CVE-2023-34103 is a high-severity cross-site scripting vulnerability in avo-hq avo, published on 5 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34103 exists.\n\nAffected packages and fixed versions:\n- avo (RubyGems): affected all versions; fixed in 2.33.3\n- avo (RubyGems): affected all versions; fixed in 2.33.3\n- avo (RubyGems): affected from 3.0.0.pre1 up to 3.0.0.pre12; no fix listed\n- avo (RubyGems): affected from 3.0.0.pre1 up to 3.0.0.pre12; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34103/ (Markdown: https://insights.sbomify.com/CVE-2023-34103/index.md)","id":"CVE-2023-34103","markdown":"https://insights.sbomify.com/CVE-2023-34103/index.md","name":"CVE-2023-34103","record":{"aliases":["GHSA-5cr9-5jx3-2g39"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails admin panel","requires_auth":"low_privilege","summary":"Attackers with form edit privileges can inject malicious scripts into HTML fields, leading to stored XSS attacks against other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"avo","vendor":"avohq"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Avo is an open source ruby on rails admin panel creation framework. In affected versions some avo fields are vulnerable to Cross Site Scripting (XSS) when rendering html based content. Attackers do need form edit privilege in order to successfully exploit this vulnerability, but the results are stored and no specific timing is required. This issue has been addressed in commit `7891c01e` which is expected to be included in the next release of avo. Users are advised to configure CSP headers for their application and to limit untrusted user access as a mitigation.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Stored XSS (Cross Site Scripting) in html content based fields of avo","id":"CVE-2023-34103","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"Regex Injection via Doctype Entities","id":"CVE-2023-34104"},"packages":[{"ecosystem":"RubyGems","fixed":["2.33.3"],"introduced":["0"],"last_affected":[],"package":"avo","purl":null,"source":"GHSA-5cr9-5jx3-2g39"},{"ecosystem":"RubyGems","fixed":["2.33.3"],"introduced":["0"],"last_affected":[],"package":"avo","purl":"pkg:gem/avo","source":"GHSA-5cr9-5jx3-2g39"},{"ecosystem":"RubyGems","fixed":[],"introduced":["3.0.0.pre1"],"last_affected":["3.0.0.pre12"],"package":"avo","purl":null,"source":"GHSA-5cr9-5jx3-2g39"},{"ecosystem":"RubyGems","fixed":[],"introduced":["3.0.0.pre1"],"last_affected":["3.0.0.pre12"],"package":"avo","purl":"pkg:gem/avo","source":"GHSA-5cr9-5jx3-2g39"}],"prev":{"headline":"Possible unsafe reflection / partial denial of service in avo","id":"CVE-2023-34102"},"products":["avo"],"published":"2023-06-05","related":[{"cvss_score":8.3,"headline":"Possible unsafe reflection / partial denial of service in avo","id":"CVE-2023-34102","kev_date_added":null,"published":"2023-06-05"},{"cvss_score":7.3,"headline":"Stored cross-site scripting (XSS) in `key_value` field in Avo","id":"CVE-2024-22191","kev_date_added":null,"published":"2024-01-16"},{"cvss_score":6.5,"headline":"Cross site scripting in Action messages on Avo","id":"CVE-2024-22411","kev_date_added":null,"published":"2024-01-16"},{"cvss_score":5.3,"headline":"Avo has a XSS vulnerability on `return_to` param","id":"CVE-2026-33209","kev_date_added":null,"published":"2026-03-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-08","vendors":["avo-hq"]},"summary":"Attackers with form edit privileges can inject malicious scripts into HTML fields, leading to stored XSS attacks against other users.","url":"https://insights.sbomify.com/CVE-2023-34103/"}