# CVE-2023-34104: Regex Injection via Doctype Entities

> An attacker can cause indefinite parser stalls via crafted entity names in fast-xml-parser, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-6w63-h3fj-q4vw

## What is CVE-2023-34104?

CVE-2023-34104 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 6 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-xml-parser is an open source, pure javascript xml parser. fast-xml-parser allows special characters in entity names, which are not escaped or sanitized. Since the entity name is used for creating a regex for searching and replacing entities in the XML body, an attacker can abuse it for denial of service (DoS) attacks. By crafting an entity name that results in an intentionally bad performing regex and utilizing it in the entity replacement step of the parser, this can cause the parser to stall for an indefinite amount of time. This problem has been resolved in v4.2.4. Users are advised to upgrade. Users unable to upgrade should avoid using DOCTYPE parsing by setting the `processEntities: false` option.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-34104?

2 open source packages ship an affected version, including fast-xml-parser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-xml-parser` | npm | From 4.1.3 | 4.2.4 |
| `fast-xml-parser` | npm | From 4.1.3 | 4.2.4 |

Products: Naturalintelligence Fast-Xml-Parser.

## How do I fix CVE-2023-34104?

Upgrade fast-xml-parser to 4.2.4 or later.

## Is CVE-2023-34104 being exploited?

There is no known exploitation of CVE-2023-34104 in the wild and no public exploit code.

## Other vulnerabilities in NaturalIntelligence fast-xml-parser

- [CVE-2026-25896](https://insights.sbomify.com/CVE-2026-25896/): fast-xml-parser has an entity encoding bypass via regex injection in DOCTYPE entity names (critical 9.3)
- [CVE-2026-33036](https://insights.sbomify.com/CVE-2026-33036/): fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278) (high 7.5)
- [CVE-2026-26278](https://insights.sbomify.com/CVE-2026-26278/): fast-xml-parser affected by DoS through entity expansion in DOCTYPE (no expansion limit) (high 7.5)
- [CVE-2026-25128](https://insights.sbomify.com/CVE-2026-25128/): fast-xml-parser has RangeError DoS Numeric Entities Bug (high 7.5)
- [CVE-2024-41818](https://insights.sbomify.com/CVE-2024-41818/): ReDOS at currency parsing fast-xml-parser (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34104 and fix it if it is affected.

What it is: CVE-2023-34104 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 6 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34104 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-xml-parser (npm): affected from 4.1.3; fixed in 4.2.4
- fast-xml-parser (npm): affected from 4.1.3; fixed in 4.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34104/ (Markdown: https://insights.sbomify.com/CVE-2023-34104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34104
- OSV: https://osv.dev/vulnerability/CVE-2023-34104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34104/
Summaries are generated and may contain mistakes; the official description above is the record.
