CVE-2023-34106 GLPI vulnerable to unauthorized access to User data

Medium 6.5 Published Updated

An authenticated user can access the list of all users and their personal information due to incorrect rights checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-34106?

CVE-2023-34106 is a medium-severity missing authorization vulnerability in Glpi-Project Glpi, published on 5 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GLPI is a free asset and IT management software package. Versions of the software starting with 0.68 and prior to 10.0.8 have an incorrect rights check on a on a file accessible by an authenticated user. This allows access to the list of all users and their personal information. Users should upgrade to version 10.0.8 to receive a patch.

Weakness: CWE-863, CWE-284

Which versions are affected by CVE-2023-34106?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2023-34106?

No fix has been published for CVE-2023-34106 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-34106 being exploited?

There is no known exploitation of CVE-2023-34106 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-923r-hqh4-wj7c, UBUNTU-CVE-2023-34106.

Is CVE-2023-34106 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free