{"answers":{"affected":"3 open source packages ship an affected version, including flask-appbuilder and Flask-AppBuilder. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34110 in the wild and no public exploit code.","fix":"Upgrade flask-appbuilder to 4.3.2 or later.","what":"CVE-2023-34110 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 22 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-34110 and fix it if it is affected.\n\nWhat it is: CVE-2023-34110 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 22 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-34110 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.2\n- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.2\n- Flask-AppBuilder (PyPI): affected all versions; fixed in 4.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34110/ (Markdown: https://insights.sbomify.com/CVE-2023-34110/index.md)","id":"CVE-2023-34110","markdown":"https://insights.sbomify.com/CVE-2023-34110/index.md","name":"CVE-2023-34110","record":{"aliases":["GHSA-jhpr-j7cq-3jp3","PYSEC-2023-94","ROOT-APP-PYPI-CVE-2023-34110"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Flask application framework","requires_auth":"high_privilege","summary":"An authenticated admin can trigger database errors that expose sensitive user data, including hashed passwords, via the UI.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flask-appbuilder","vendor":"flask-appbuilder_project"}],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Flask-AppBuilder vulnerable to possible disclosure of sensitive information on user error","id":"CVE-2023-34110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2023"},"n_packages":3,"n_references":4,"next":{"headline":"Command Injection Vulnerability in `Release PR Merged` Workflow in taosdata/grafanaplugin","id":"CVE-2023-34111"},"packages":[{"ecosystem":"PyPI","fixed":["4.3.2"],"introduced":["0"],"last_affected":[],"package":"Flask-AppBuilder","purl":null,"source":"GHSA-jhpr-j7cq-3jp3"},{"ecosystem":"PyPI","fixed":["4.3.2"],"introduced":["0"],"last_affected":[],"package":"flask-appbuilder","purl":"pkg:pypi/flask-appbuilder","source":"GHSA-jhpr-j7cq-3jp3"},{"ecosystem":"PyPI","fixed":["4.3.2"],"introduced":["0"],"last_affected":[],"package":"flask-appbuilder","purl":"pkg:pypi/flask-appbuilder","source":"PYSEC-2023-94"}],"prev":{"headline":"User input results in Unbounded resource consumption in @zxcvbn-ts/core","id":"CVE-2023-34109"},"products":["Flask-AppBuilder"],"published":"2023-06-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-06","vendors":["dpgaspar"]},"summary":"An authenticated admin can trigger database errors that expose sensitive user data, including hashed passwords, via the UI.","url":"https://insights.sbomify.com/CVE-2023-34110/"}