# CVE-2023-34110: Flask-AppBuilder vulnerable to possible disclosure of sensitive information on user error

> An authenticated admin can trigger database errors that expose sensitive user data, including hashed passwords, via the UI.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2023
- **Updated:** 6 Dec 2024
- **Also known as:** GHSA-jhpr-j7cq-3jp3, PYSEC-2023-94, ROOT-APP-PYPI-CVE-2023-34110

## What is CVE-2023-34110?

CVE-2023-34110 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 22 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2023-34110?

3 open source packages ship an affected version, including flask-appbuilder and Flask-AppBuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | All versions | 4.3.2 |
| `flask-appbuilder` | PyPI | All versions | 4.3.2 |
| `Flask-AppBuilder` | PyPI | All versions | 4.3.2 |

Products: Flask-Appbuilder Project Flask-Appbuilder.

## How do I fix CVE-2023-34110?

Upgrade flask-appbuilder to 4.3.2 or later.

## Is CVE-2023-34110 being exploited?

There is no known exploitation of CVE-2023-34110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34110 and fix it if it is affected.

What it is: CVE-2023-34110 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 22 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34110 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.2
- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.2
- Flask-AppBuilder (PyPI): affected all versions; fixed in 4.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34110/ (Markdown: https://insights.sbomify.com/CVE-2023-34110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34110
- OSV: https://osv.dev/vulnerability/CVE-2023-34110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34110/
Summaries are generated and may contain mistakes; the official description above is the record.
