CVE-2023-34149 Apache Struts: DoS via OOM owing to not properly checking of list bounds
Attackers can cause denial of service via out-of-memory errors due to improper list bounds checking in Apache Struts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-34149?
CVE-2023-34149 is a medium-severity denial of service vulnerability in Apache Struts, published on 14 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Software Foundation Apache Struts.This issue affects Apache Struts: through 2.5.30, through 6.1.2.
Upgrade to Struts 2.5.31 or 6.1.2.1 or greater.
Weakness: CWE-770
Which versions are affected by CVE-2023-34149?
4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | All versions | 2.5.31 |
org.apache.struts:struts2-core Maven | All versions | 2.5.31 |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.1.2.1 |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.1.2.1 |
Products include Apache Struts.
How do I fix CVE-2023-34149?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.5.31 or 6.1.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-34149 being exploited?
There is no known exploitation of CVE-2023-34149 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-8f6x-v685-g2xc.