# CVE-2023-34149: Apache Struts: DoS via OOM owing to not properly checking of list bounds

> Attackers can cause denial of service via out-of-memory errors due to improper list bounds checking in Apache Struts.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-8f6x-v685-g2xc

## What is CVE-2023-34149?

CVE-2023-34149 is a medium-severity denial of service vulnerability in Apache Struts, published on 14 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Allocation of Resources Without Limits or Throttling vulnerability in Apache Software Foundation Apache Struts.This issue affects Apache Struts: through 2.5.30, through 6.1.2.

Upgrade to Struts 2.5.31 or 6.1.2.1 or greater.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-34149?

4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.5.31 |
| `org.apache.struts:struts2-core` | Maven | All versions | 2.5.31 |
| `org.apache.struts:struts2-core` | Maven | From 6.0.0 | 6.1.2.1 |
| `org.apache.struts:struts2-core` | Maven | From 6.0.0 | 6.1.2.1 |

Products: Apache Struts.

## How do I fix CVE-2023-34149?

Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.5.31 or 6.1.2.1.

## Is CVE-2023-34149 being exploited?

There is no known exploitation of CVE-2023-34149 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34149 and fix it if it is affected.

What it is: CVE-2023-34149 is a medium-severity denial of service vulnerability in Apache Struts, published on 14 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34149 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.5.31
- org.apache.struts:struts2-core (Maven): affected all versions; fixed in 2.5.31
- org.apache.struts:struts2-core (Maven): affected from 6.0.0; fixed in 6.1.2.1
- org.apache.struts:struts2-core (Maven): affected from 6.0.0; fixed in 6.1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34149/ (Markdown: https://insights.sbomify.com/CVE-2023-34149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34149
- OSV: https://osv.dev/vulnerability/CVE-2023-34149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34149/
Summaries are generated and may contain mistakes; the official description above is the record.
