# CVE-2023-34212: Apache NiFi: Potential Deserialization of Untrusted Data with JNDI in JMS Components

> Authenticated users can trigger remote code execution via unsafe JNDI deserialization in JMS components by configuring malicious URLs.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-nifi-2023-34212, GHSA-65wh-g8x8-gm2h

## What is CVE-2023-34212?

CVE-2023-34212 is a medium-severity unsafe deserialization vulnerability in Apache Nifi, published on 12 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The JndiJmsConnectionFactoryProvider Controller Service, along with the ConsumeJMS and PublishJMS Processors, in Apache NiFi 1.8.0 through 1.21.0 allow an authenticated and authorized user to configure URL and library properties that enable deserialization of untrusted data from a remote location.

The resolution validates the JNDI URL and restricts locations to a set of allowed schemes.

You are recommended to upgrade to version 1.22.0 or later which fixes this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-34212?

3 open source packages ship an affected version, including org.apache.nifi:nifi-jms-processors and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-jms-processors` | Maven | From 1.8.0 | 1.22.0 |
| `org.apache.nifi:nifi-jms-processors` | Maven | From 1.8.0 | 1.22.0 |
| `nifi` | Bitnami | From 1.8.0 to 1.21.0 | None |

Products: Apache Nifi.

## How do I fix CVE-2023-34212?

Upgrade org.apache.nifi:nifi-jms-processors to 1.22.0 or later.

## Is CVE-2023-34212 being exploited?

There is no known exploitation of CVE-2023-34212 in the wild and no public exploit code.

Public exploit code:

- CVE-2023-34212: Java Deserialization via JNDI Components in Apache NiFi (github_poc): https://github.com/mbadanoiu/CVE-2023-34212

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34212 and fix it if it is affected.

What it is: CVE-2023-34212 is a medium-severity unsafe deserialization vulnerability in Apache Nifi, published on 12 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34212 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-jms-processors (Maven): affected from 1.8.0; fixed in 1.22.0
- org.apache.nifi:nifi-jms-processors (Maven): affected from 1.8.0; fixed in 1.22.0
- nifi (Bitnami): affected from 1.8.0 up to 1.21.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34212/ (Markdown: https://insights.sbomify.com/CVE-2023-34212/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34212
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34212
- OSV: https://osv.dev/vulnerability/CVE-2023-34212

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34212/
Summaries are generated and may contain mistakes; the official description above is the record.
