# CVE-2023-34233: Snowflake Python Connector vulnerable to Command Injection

> Attackers can achieve remote code execution by tricking users into visiting a malicious SSO URL, requiring an upgrade to the Snowflake Python Connector.

- **Severity:** High 7.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jun 2023
- **Updated:** 6 Jan 2025
- **Also known as:** GHSA-5w5m-pfw9-c8fp, PYSEC-2023-88

## What is CVE-2023-34233?

CVE-2023-34233 is a high-severity command injection vulnerability in snowflakedb snowflake-connector-python, published on 8 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Versions prior to 3.0.2 are vulnerable to command injection via single sign-on(SSO) browser URL authentication. In order to exploit the potential for command injection, an attacker would need to be successful in (1) establishing a malicious resource and (2) redirecting users to utilize the resource. The attacker could set up a malicious, publicly accessible server which responds to the SSO URL with an attack payload. If the attacker then tricked a user into visiting the maliciously crafted connection URL, the user’s local machine would render the malicious payload, leading to a remote code execution. This attack scenario can be mitigated through URL whitelisting as well as common anti-phishing resources. Version 3.0.2 contains a patch for this issue.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2023-34233?

3 open source packages ship an affected version, including snowflake-connector-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snowflake-connector-python` | PyPI | All versions | 3.0.2 |
| `snowflake-connector-python` | PyPI | All versions | 3.0.2 |
| `snowflake-connector-python` | PyPI | All versions | 3.0.2 |

Products: Snowflake Snowflake Connector.

## How do I fix CVE-2023-34233?

Upgrade snowflake-connector-python to 3.0.2 or later.

## Is CVE-2023-34233 being exploited?

There is no known exploitation of CVE-2023-34233 in the wild and no public exploit code.

Public exploit code:

- https://github.com/nayankadamm/CVE-2023-34233_Proof_OF_Concept (github_poc): https://github.com/nayankadamm/CVE-2023-34233_Proof_OF_Concept

## Other vulnerabilities in snowflakedb snowflake-connector-python

- [CVE-2023-34230](https://insights.sbomify.com/CVE-2023-34230/): Snowflake Connector vulnerable to Command Injection (high 7.3)
- [CVE-2023-34232](https://insights.sbomify.com/CVE-2023-34232/): Snowflake NodeJS Driver vulnerable to Command Injection (high 7.3)
- [CVE-2025-24793](https://insights.sbomify.com/CVE-2025-24793/): Snowflake Connector for Python has an SQL Injection in write_pandas (high 7.0)
- [CVE-2025-24794](https://insights.sbomify.com/CVE-2025-24794/): The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache (medium 6.7)
- [CVE-2023-51662](https://insights.sbomify.com/CVE-2023-51662/): Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL) (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34233 and fix it if it is affected.

What it is: CVE-2023-34233 is a high-severity command injection vulnerability in snowflakedb snowflake-connector-python, published on 8 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-34233 in the wild and no public exploit code.

Affected packages and fixed versions:
- snowflake-connector-python (PyPI): affected all versions; fixed in 3.0.2
- snowflake-connector-python (PyPI): affected all versions; fixed in 3.0.2
- snowflake-connector-python (PyPI): affected all versions; fixed in 3.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34233/ (Markdown: https://insights.sbomify.com/CVE-2023-34233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34233
- OSV: https://osv.dev/vulnerability/CVE-2023-34233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34233/
Summaries are generated and may contain mistakes; the official description above is the record.
