# CVE-2023-34234: Governor proposal creation may be blocked by frontrunning in OpenZeppelin

> Attackers can frontrun proposal creation to block governance actions or gain proposer privileges in OpenZeppelin smart contracts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2023
- **Updated:** 6 Feb 2025
- **Also known as:** GHSA-5h3x-9wvq-w4m2

## What is CVE-2023-34234?

CVE-2023-34234 is a medium-severity vulnerability in openzeppelin-contracts, published on 7 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for smart contract development. By frontrunning the creation of a proposal, an attacker can become the proposer and gain the ability to cancel it. The attacker can do this repeatedly to try to prevent a proposal from being proposed at all. This impacts the `Governor` contract in v4.9.0 only, and the `GovernorCompatibilityBravo` contract since v4.3.0. This problem has been patched in 4.9.1 by introducing opt-in frontrunning protection. Users are advised to upgrade. Users unable to upgrade may submit the proposal creation transaction to an endpoint with frontrunning protection as a workaround.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-34234?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.3.0 | 4.9.1 |
| `@openzeppelin/contracts` | npm | From 4.3.0 | 4.9.1 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.3.0 | 4.9.1 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.3.0 | 4.9.1 |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

## How do I fix CVE-2023-34234?

Upgrade @openzeppelin/contracts to 4.9.1 or later.

## Is CVE-2023-34234 being exploited?

There is no known exploitation of CVE-2023-34234 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34234 and fix it if it is affected.

What it is: CVE-2023-34234 is a medium-severity vulnerability in openzeppelin-contracts, published on 7 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34234 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.9.1
- @openzeppelin/contracts (npm): affected from 4.3.0; fixed in 4.9.1
- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.9.1
- @openzeppelin/contracts-upgradeable (npm): affected from 4.3.0; fixed in 4.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34234/ (Markdown: https://insights.sbomify.com/CVE-2023-34234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34234
- OSV: https://osv.dev/vulnerability/CVE-2023-34234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34234/
Summaries are generated and may contain mistakes; the official description above is the record.
