# CVE-2023-34235: Leaking sensitive user information still possible by filtering on private with prefix fields

> Attackers can leak sensitive data like admin passwords by exploiting a prefix filtering bypass in Strapi's query builder.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-9xg4-3qfm-9w8f

## What is CVE-2023-34235?

CVE-2023-34235 is a high-severity vulnerability in strapi, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strapi is an open-source headless content management system. Prior to version 4.10.8, it is possible to leak private fields if one is using the `t(number)` prefix. Knex query allows users to change the default prefix. For example, if someone changes the prefix to be the same as it was before or to another table they want to query, the query changes from `password` to `t1.password`. `password` is protected by filtering protections but `t1.password` is not protected. This can lead to filtering attacks on everything related to the object again, including admin passwords and reset-tokens. Version 4.10.8 fixes this issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-34235?

4 open source packages ship an affected version, including @strapi/database and @strapi/utils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/database` | npm | All versions | 4.10.8 |
| `@strapi/database` | npm | All versions | 4.10.8 |
| `@strapi/utils` | npm | All versions | 4.10.8 |
| `@strapi/utils` | npm | All versions | 4.10.8 |

Products: Strapi Strapi.

## How do I fix CVE-2023-34235?

Upgrade @strapi/database to 4.10.8 or later.

## Is CVE-2023-34235 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34235 exists.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34235 and fix it if it is affected.

What it is: CVE-2023-34235 is a high-severity vulnerability in strapi, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34235 exists.

Affected packages and fixed versions:
- @strapi/database (npm): affected all versions; fixed in 4.10.8
- @strapi/database (npm): affected all versions; fixed in 4.10.8
- @strapi/utils (npm): affected all versions; fixed in 4.10.8
- @strapi/utils (npm): affected all versions; fixed in 4.10.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34235/ (Markdown: https://insights.sbomify.com/CVE-2023-34235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34235
- OSV: https://osv.dev/vulnerability/CVE-2023-34235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34235/
Summaries are generated and may contain mistakes; the official description above is the record.
