CVE-2023-34238 Local File Inclusion vulnerability in Gatsby
Attackers can read arbitrary files from the server if the Gatsby development server is exposed to non-localhost interfaces.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-34238?
CVE-2023-34238 is a medium-severity path traversal vulnerability in gatsbyjs gatsby, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Gatsby is a free and open source framework based on React. The Gatsby framework prior to versions 4.25.7 and 5.9.1 contain a Local File Inclusion vulnerability in the `__file-code-frame` and `__original-stack-frame` paths, exposed when running the Gatsby develop server (`gatsby develop`). Any file in scope of the development server could potentially be exposed. It should be noted that by default `gatsby develop` is only accessible via the localhost `127.0.0.1`, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as `--host 0.0.0.0`, `-H 0.0.0.0`, or the `GATSBY_HOST=0.0.0.0` environment variable. A patch has been introduced in `[email protected]` and `[email protected]` which mitigates the issue. Users are advised to upgrade. Users unable to upgrade should avoid exposing their development server to the internet.
Weakness: CWE-22
Which versions are affected by CVE-2023-34238?
4 open source packages ship an affected version, including gatsby. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gatsby npm | All versions | 4.25.7 |
gatsby npm | All versions | 4.25.7 |
gatsby npm | From 5.0.0 | 5.9.1 |
gatsby npm | From 5.0.0 | 5.9.1 |
Products include Gatsbyjs Gatsby.
How do I fix CVE-2023-34238?
Upgrade gatsby to a fixed version for your release line: 4.25.7 or 5.9.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2023-34238 being exploited?
There is no known exploitation of CVE-2023-34238 in the wild and no public exploit code.
Sources
Also known as CLSA-2026-1792689158, GHSA-c6f8-8r25-c4gc.