{"answers":{"affected":"4 open source packages ship an affected version, including gatsby. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34238 in the wild and no public exploit code.","fix":"Upgrade gatsby to a fixed version for your release line: 4.25.7 or 5.9.1.","what":"CVE-2023-34238 is a medium-severity path traversal vulnerability in gatsbyjs gatsby, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-34238 and fix it if it is affected.\n\nWhat it is: CVE-2023-34238 is a medium-severity path traversal vulnerability in gatsbyjs gatsby, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-34238 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gatsby (npm): affected all versions; fixed in 4.25.7\n- gatsby (npm): affected all versions; fixed in 4.25.7\n- gatsby (npm): affected from 5.0.0; fixed in 5.9.1\n- gatsby (npm): affected from 5.0.0; fixed in 5.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34238/ (Markdown: https://insights.sbomify.com/CVE-2023-34238/index.md)","id":"CVE-2023-34238","markdown":"https://insights.sbomify.com/CVE-2023-34238/index.md","name":"CVE-2023-34238","record":{"aliases":["CLSA-2026-1792689158","GHSA-c6f8-8r25-c4gc"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Gatsby framework","requires_auth":"low_privilege","summary":"Attackers can read arbitrary files from the server if the Gatsby development server is exposed to non-localhost interfaces.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gatsby","vendor":"gatsbyjs"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Gatsby is a free and open source framework based on React. The Gatsby framework prior to versions 4.25.7 and 5.9.1 contain a Local File Inclusion vulnerability in the `__file-code-frame` and `__original-stack-frame` paths, exposed when running the Gatsby develop server (`gatsby develop`). Any file in scope of the development server could potentially be exposed. It should be noted that by default `gatsby develop` is only accessible via the localhost `127.0.0.1`, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as `--host 0.0.0.0`, `-H 0.0.0.0`, or the `GATSBY_HOST=0.0.0.0` environment variable. A patch has been introduced in `gatsby@5.9.1` and `gatsby@4.25.7` which mitigates the issue. Users are advised to upgrade. Users unable to upgrade should avoid exposing their development server to the internet.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Local File Inclusion vulnerability in Gatsby","id":"CVE-2023-34238","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":4,"n_references":3,"next":{"headline":"Unfiltered paths in gradio","id":"CVE-2023-34239"},"packages":[{"ecosystem":"npm","fixed":["4.25.7"],"introduced":["0"],"last_affected":[],"package":"gatsby","purl":null,"source":"GHSA-c6f8-8r25-c4gc"},{"ecosystem":"npm","fixed":["4.25.7"],"introduced":["0"],"last_affected":[],"package":"gatsby","purl":"pkg:npm/gatsby","source":"GHSA-c6f8-8r25-c4gc"},{"ecosystem":"npm","fixed":["5.9.1"],"introduced":["5.0.0"],"last_affected":[],"package":"gatsby","purl":null,"source":"GHSA-c6f8-8r25-c4gc"},{"ecosystem":"npm","fixed":["5.9.1"],"introduced":["5.0.0"],"last_affected":[],"package":"gatsby","purl":"pkg:npm/gatsby","source":"GHSA-c6f8-8r25-c4gc"}],"prev":{"headline":"Remote code execution via specially crafted script settings in SABnzbd","id":"CVE-2023-34237"},"products":["gatsby"],"published":"2023-06-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-06","vendors":["gatsbyjs"]},"summary":"Attackers can read arbitrary files from the server if the Gatsby development server is exposed to non-localhost interfaces.","url":"https://insights.sbomify.com/CVE-2023-34238/"}