# CVE-2023-34238: Local File Inclusion vulnerability in Gatsby

> Attackers can read arbitrary files from the server if the Gatsby development server is exposed to non-localhost interfaces.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2023
- **Updated:** 6 Jan 2025
- **Also known as:** CLSA-2026-1792689158, GHSA-c6f8-8r25-c4gc

## What is CVE-2023-34238?

CVE-2023-34238 is a medium-severity path traversal vulnerability in gatsbyjs gatsby, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Gatsby is a free and open source framework based on React. The Gatsby framework prior to versions 4.25.7 and 5.9.1 contain a Local File Inclusion vulnerability in the `__file-code-frame` and `__original-stack-frame` paths, exposed when running the Gatsby develop server (`gatsby develop`). Any file in scope of the development server could potentially be exposed. It should be noted that by default `gatsby develop` is only accessible via the localhost `127.0.0.1`, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as `--host 0.0.0.0`, `-H 0.0.0.0`, or the `GATSBY_HOST=0.0.0.0` environment variable. A patch has been introduced in `gatsby@5.9.1` and `gatsby@4.25.7` which mitigates the issue. Users are advised to upgrade. Users unable to upgrade should avoid exposing their development server to the internet.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-34238?

4 open source packages ship an affected version, including gatsby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gatsby` | npm | All versions | 4.25.7 |
| `gatsby` | npm | All versions | 4.25.7 |
| `gatsby` | npm | From 5.0.0 | 5.9.1 |
| `gatsby` | npm | From 5.0.0 | 5.9.1 |

Products: Gatsbyjs Gatsby.

## How do I fix CVE-2023-34238?

Upgrade gatsby to a fixed version for your release line: 4.25.7 or 5.9.1.

## Is CVE-2023-34238 being exploited?

There is no known exploitation of CVE-2023-34238 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34238 and fix it if it is affected.

What it is: CVE-2023-34238 is a medium-severity path traversal vulnerability in gatsbyjs gatsby, published on 7 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34238 in the wild and no public exploit code.

Affected packages and fixed versions:
- gatsby (npm): affected all versions; fixed in 4.25.7
- gatsby (npm): affected all versions; fixed in 4.25.7
- gatsby (npm): affected from 5.0.0; fixed in 5.9.1
- gatsby (npm): affected from 5.0.0; fixed in 5.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34238/ (Markdown: https://insights.sbomify.com/CVE-2023-34238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34238
- OSV: https://osv.dev/vulnerability/CVE-2023-34238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34238/
Summaries are generated and may contain mistakes; the official description above is the record.
