{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34240 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-34240 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-34240 is a medium-severity vulnerability in CloudExplorer-Dev CloudExplorer-Lite, published on 27 Jun 2023."},"fix_prompt":"Check this codebase for CVE-2023-34240 and fix it if it is affected.\n\nWhat it is: CVE-2023-34240 is a medium-severity vulnerability in CloudExplorer-Dev CloudExplorer-Lite, published on 27 Jun 2023. \nExploitation: There is no known exploitation of CVE-2023-34240 in the wild and no public exploit code.\n\nAffected product: CloudExplorer-Dev CloudExplorer-Lite. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34240/ (Markdown: https://insights.sbomify.com/CVE-2023-34240/index.md)","id":"CVE-2023-34240","markdown":"https://insights.sbomify.com/CVE-2023-34240/index.md","name":"CVE-2023-34240","record":{"aliases":["GHSA-px4m-5j22-5mw4"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"cloudexplorer_lite","vendor":"fit2cloud"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-521","name":"Weak Password Requirements"}],"description":"Cloudexplorer-lite is an open source cloud software stack. Weak passwords can be easily guessed and are an easy target for brute force attacks. This can lead to an authentication system failure and compromise system security. Versions of cloudexplorer-lite prior to 1.2.0 did not enforce strong passwords. This vulnerability has been fixed in version 1.2.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Weak passwords allowed in cloudexplorer-lite","id":"CVE-2023-34240","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2023"},"n_packages":0,"n_references":1,"next":{"headline":"CUPS vulnerable to use-after-free in cupsdAcceptClient()","id":"CVE-2023-34241"},"packages":[],"prev":{"headline":"Unfiltered paths in gradio","id":"CVE-2023-34239"},"products":["CloudExplorer-Lite"],"published":"2023-06-27","related":[{"cvss_score":9.8,"headline":"Command injection vulnerability in module management function in CloudExplorer Lite","id":"CVE-2023-38692","kev_date_added":null,"published":"2023-08-04"},{"cvss_score":8.8,"headline":"Improper Access Control in cloudexplorer-dev/cloudexplorer-lite","id":"CVE-2023-2845","kev_date_added":null,"published":"2023-05-23"},{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2023-50612","kev_date_added":null,"published":"2024-01-06"},{"cvss_score":7.5,"headline":"CloudExplorer Lite permission bypass vulnerability","id":"CVE-2023-44397","kev_date_added":null,"published":"2023-10-30"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2023-42147","kev_date_added":null,"published":"2023-09-20"},{"cvss_score":7.5,"headline":"CloudExplorer Lite sensitive information leakage vulnerability","id":"CVE-2023-39519","kev_date_added":null,"published":"2023-08-24"},{"cvss_score":7.2,"headline":"Authorization Bypass Through User-Controlled Key in cloudexplorer-dev/cloudexplorer-lite","id":"CVE-2023-2844","kev_date_added":null,"published":"2023-05-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-27","vendors":["CloudExplorer-Dev"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-34240/"}