# CVE-2023-34240: Weak passwords allowed in cloudexplorer-lite


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Jun 2023
- **Updated:** 27 Nov 2024
- **Also known as:** GHSA-px4m-5j22-5mw4

## What is CVE-2023-34240?

CVE-2023-34240 is a medium-severity vulnerability in CloudExplorer-Dev CloudExplorer-Lite, published on 27 Jun 2023. 

### Official description

Cloudexplorer-lite is an open source cloud software stack. Weak passwords can be easily guessed and are an easy target for brute force attacks. This can lead to an authentication system failure and compromise system security. Versions of cloudexplorer-lite prior to 1.2.0 did not enforce strong passwords. This vulnerability has been fixed in version 1.2.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2023-34240?

It affects 1 product.


Products: Fit2cloud Cloudexplorer Lite.

## How do I fix CVE-2023-34240?

No fix has been published for CVE-2023-34240 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-34240 being exploited?

There is no known exploitation of CVE-2023-34240 in the wild and no public exploit code.

## Other vulnerabilities in CloudExplorer-Dev CloudExplorer-Lite

- [CVE-2023-38692](https://insights.sbomify.com/CVE-2023-38692/): Command injection vulnerability in module management function in CloudExplorer Lite (critical 9.8)
- [CVE-2023-2845](https://insights.sbomify.com/CVE-2023-2845/): Improper Access Control in cloudexplorer-dev/cloudexplorer-lite (high 8.8)
- [CVE-2023-50612](https://insights.sbomify.com/CVE-2023-50612/): Privilege escalation in n/a (high 7.8)
- [CVE-2023-44397](https://insights.sbomify.com/CVE-2023-44397/): CloudExplorer Lite permission bypass vulnerability (high 7.5)
- [CVE-2023-42147](https://insights.sbomify.com/CVE-2023-42147/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34240 and fix it if it is affected.

What it is: CVE-2023-34240 is a medium-severity vulnerability in CloudExplorer-Dev CloudExplorer-Lite, published on 27 Jun 2023. 
Exploitation: There is no known exploitation of CVE-2023-34240 in the wild and no public exploit code.

Affected product: CloudExplorer-Dev CloudExplorer-Lite. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34240/ (Markdown: https://insights.sbomify.com/CVE-2023-34240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34240
- OSV: https://osv.dev/vulnerability/CVE-2023-34240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34240/
Summaries are generated and may contain mistakes; the official description above is the record.
