CVE-2023-34244 GLPI vulnerable to reflected XSS in search pages

Medium 6.5 Published Updated

An unauthenticated attacker can craft a malicious link to execute arbitrary scripts in the browser of an authenticated GLPI user.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2023-34244?

CVE-2023-34244 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 5 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

GLPI is a free asset and IT management software package. Starting in version 9.4.0 and prior to version 10.0.8, a malicious link can be crafted by an unauthenticated user that can exploit a reflected XSS in case any authenticated user opens the crafted link. Users should upgrade to version 10.0.8 to receive a patch.

Weakness: CWE-79

Which versions are affected by CVE-2023-34244?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2023-34244?

No fix has been published for CVE-2023-34244 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-34244 being exploited?

There is no known exploitation of CVE-2023-34244 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-p93p-pwg9-w95w, UBUNTU-CVE-2023-34244.

Is CVE-2023-34244 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free