{"answers":{"affected":"2 open source packages ship an affected version, including @udecode/plate-link. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34245 in the wild and no public exploit code.","fix":"Upgrade @udecode/plate-link to 20.0.0 or later.","what":"CVE-2023-34245 is a high-severity cross-site scripting vulnerability in udecode plate, published on 9 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-34245 and fix it if it is affected.\n\nWhat it is: CVE-2023-34245 is a high-severity cross-site scripting vulnerability in udecode plate, published on 9 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-34245 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @udecode/plate-link (npm): affected all versions; fixed in 20.0.0\n- @udecode/plate-link (npm): affected all versions; fixed in 20.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34245/ (Markdown: https://insights.sbomify.com/CVE-2023-34245/index.md)","id":"CVE-2023-34245","markdown":"https://insights.sbomify.com/CVE-2023-34245/index.md","name":"CVE-2023-34245","record":{"aliases":["GHSA-4882-hxpr-hrvm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"React rich-text editor plugin","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via unsanitized javascript: URLs in the Plate editor link plugin, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"plate","vendor":"udecode"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"@udecode/plate-link is the link handler for the udecode/plate rich-text editor plugin system for Slate \u0026 React. Affected versions of the link plugin and link UI component do not sanitize URLs to prevent use of the `javascript:` scheme. As a result, links with JavaScript URLs can be inserted into the Plate editor through various means, including opening or pasting malicious content. `@udecode/plate-link` 20.0.0 resolves this issue by introducing an `allowedSchemes` option to the link plugin, defaulting to `['http', 'https', 'mailto', 'tel']`. URLs using a scheme that isn't in this list will not be rendered to the DOM. Users are advised to upgrade. Users unable to upgrade are advised to override the `LinkElement` and `PlateFloatingLink` components with implementations that explicitly check the URL scheme before rendering any anchor elements.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross site scripting (XSS) in @udecode/plate-link","id":"CVE-2023-34245","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Doorkeeper Improper Authentication vulnerability","id":"CVE-2023-34246"},"packages":[{"ecosystem":"npm","fixed":["20.0.0"],"introduced":["0"],"last_affected":[],"package":"@udecode/plate-link","purl":null,"source":"GHSA-4882-hxpr-hrvm"},{"ecosystem":"npm","fixed":["20.0.0"],"introduced":["0"],"last_affected":[],"package":"@udecode/plate-link","purl":"pkg:npm/%40udecode/plate-link","source":"GHSA-4882-hxpr-hrvm"}],"prev":{"headline":"GLPI vulnerable to reflected XSS in search pages","id":"CVE-2023-34244"},"products":["plate"],"published":"2023-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-01-06","vendors":["udecode"]},"summary":"Attackers can execute arbitrary JavaScript via unsanitized javascript: URLs in the Plate editor link plugin, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2023-34245/"}