{"answers":{"affected":"2 open source packages ship an affected version, including doorkeeper. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34246 exists.","fix":"Upgrade doorkeeper to 5.6.6 or later.","what":"CVE-2023-34246 is a medium-severity authentication bypass vulnerability in doorkeeper-gem doorkeeper, published on 12 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-34246 and fix it if it is affected.\n\nWhat it is: CVE-2023-34246 is a medium-severity authentication bypass vulnerability in doorkeeper-gem doorkeeper, published on 12 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34246 exists.\n\nAffected packages and fixed versions:\n- doorkeeper (RubyGems): affected all versions; fixed in 5.6.6\n- doorkeeper (RubyGems): affected all versions; fixed in 5.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34246/ (Markdown: https://insights.sbomify.com/CVE-2023-34246/index.md)","id":"CVE-2023-34246","markdown":"https://insights.sbomify.com/CVE-2023-34246/index.md","name":"CVE-2023-34246","record":{"aliases":["DEBIAN-CVE-2023-34246","DLA-3494-1","DLA-3989-1","GHSA-7w2c-w47h-789w","UBUNTU-CVE-2023-34246","USN-6210-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OAuth library","requires_auth":"none","summary":"Doorkeeper library allows public clients to bypass user consent for previously approved authorization requests, enabling potential impersonation.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"doorkeeper","vendor":"doorkeeper_project"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Doorkeeper is an OAuth 2 provider for Ruby on Rails / Grape. Prior to version 5.6.6, Doorkeeper automatically processes authorization requests without user consent for public clients that have been previous approved. Public clients are inherently vulnerable to impersonation, their identity cannot be assured. This issue is fixed in version 5.6.6.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Doorkeeper Improper Authentication vulnerability","id":"CVE-2023-34246","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":2,"n_references":6,"next":{"headline":"@keystone-6/auth Open Redirect vulnerability","id":"CVE-2023-34247"},"packages":[{"ecosystem":"RubyGems","fixed":["5.6.6"],"introduced":["0"],"last_affected":[],"package":"doorkeeper","purl":null,"source":"GHSA-7w2c-w47h-789w"},{"ecosystem":"RubyGems","fixed":["5.6.6"],"introduced":["0"],"last_affected":[],"package":"doorkeeper","purl":"pkg:gem/doorkeeper","source":"GHSA-7w2c-w47h-789w"}],"prev":{"headline":"Cross site scripting (XSS) in @udecode/plate-link","id":"CVE-2023-34245"},"products":["doorkeeper"],"published":"2023-06-12","related":[{"cvss_score":9.1,"headline":"Doorkeeper is vulnerable to replay attacks","id":"CVE-2016-6582","kev_date_added":null,"published":"2017-01-23"},{"cvss_score":7.5,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper","id":"CVE-2020-10187","kev_date_added":null,"published":"2020-05-04"},{"cvss_score":7.5,"headline":"Doorkeeper subject to Incorrect Permission Assignment","id":"CVE-2018-1000211","kev_date_added":null,"published":"2018-07-13"},{"cvss_score":6.8,"headline":"Doorkeeper vulnerable to Cross-site Request Forgery","id":"CVE-2014-8144","kev_date_added":null,"published":"2014-12-31"},{"cvss_score":6.1,"headline":"Doorkeeper is vulnerable to stored XSS and code execution","id":"CVE-2018-1000088","kev_date_added":null,"published":"2018-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["doorkeeper-gem"]},"summary":"Doorkeeper library allows public clients to bypass user consent for previously approved authorization requests, enabling potential impersonation.","url":"https://insights.sbomify.com/CVE-2023-34246/"}