{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34254 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-34254 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-34254 is a high-severity command injection vulnerability in glpi-project glpi-agent, published on 23 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-34254 and fix it if it is affected.\n\nWhat it is: CVE-2023-34254 is a high-severity command injection vulnerability in glpi-project glpi-agent, published on 23 Jun 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-34254 in the wild and no public exploit code.\n\nAffected product: glpi-project glpi-agent. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34254/ (Markdown: https://insights.sbomify.com/CVE-2023-34254/index.md)","id":"CVE-2023-34254","markdown":"https://insights.sbomify.com/CVE-2023-34254/index.md","name":"CVE-2023-34254","record":{"aliases":["GHSA-39vc-hxgm-j465","UBUNTU-CVE-2023-34254"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation","data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"GLPI management agent","requires_auth":"high_privilege","summary":"A malicious remote user can inject commands into the GLPI Agent's SSH inventory workflow, potentially gaining high privileges and disclosing credentials.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"glpi_agent","vendor":"glpi-project"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The GLPI Agent is a generic management agent. Prior to version 1.5, if glpi-agent is running remoteinventory task against an Unix platform with ssh command, an administrator user on the remote can manage to inject a command in a specific workflow the agent would run with the privileges it uses. In the case, the agent is running with administration privileges, a malicious user could gain high privileges on the computer glpi-agent is running on. A malicious user could also disclose all remote accesses the agent is configured with for remoteinventory task. This vulnerability has been patched in glpi-agent 1.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Remote inventory task command injection when using ssh command mode","id":"CVE-2023-34254","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2023-34256"},"packages":[],"prev":{"headline":"Grav vulnerable to Server-side Template Injection (SSTI) via Denylist Bypass","id":"CVE-2023-34253"},"products":["glpi-agent"],"published":"2023-06-23","related":[{"cvss_score":7.3,"headline":"GLPI-Agent's MSI package installation permits local users to change Agent configuration","id":"CVE-2024-28240","kev_date_added":null,"published":"2024-04-25"},{"cvss_score":7.3,"headline":"GlPI-Agent MSI package installation doesn't update folder security profile when using non default installation folder","id":"CVE-2024-28241","kev_date_added":null,"published":"2024-04-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-27","vendors":["glpi-project"]},"summary":"A malicious remote user can inject commands into the GLPI Agent's SSH inventory workflow, potentially gaining high privileges and disclosing credentials.","url":"https://insights.sbomify.com/CVE-2023-34254/"}