CVE-2023-34340 Apache Accumulo: Accumulo 2.1.0 may incorrectly validate cached credentials

Critical 9.8 Published Updated

Attackers can bypass authentication in Apache Accumulo by providing invalid credentials due to improper validation of cached credentials.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-34340?

CVE-2023-34340 is a critical authentication bypass vulnerability in Apache Accumulo, published on 21 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Authentication vulnerability in Apache Software Foundation Apache Accumulo. This issue affects Apache Accumulo: 2.1.0.

Accumulo 2.1.0 contains a defect in the user authentication process that may succeed when invalid credentials are provided. Users are advised to upgrade to 2.1.1.

Weakness: CWE-287

Which versions are affected by CVE-2023-34340?

2 open source packages ship an affected version, including org.apache.accumulo:accumulo-shell. It affects 1 product.

PackageAffectedFixed in
org.apache.accumulo:accumulo-shell MavenFrom 2.1.02.1.1
org.apache.accumulo:accumulo-shell MavenFrom 2.1.02.1.1

Products include Apache Accumulo.

How do I fix CVE-2023-34340?

Upgrade org.apache.accumulo:accumulo-shell to 2.1.1 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2023-34340 being exploited?

There is no known exploitation of CVE-2023-34340 in the wild and no public exploit code.

Sources

Also known as GHSA-hp5w-w29m-vg63.

Is CVE-2023-34340 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free