{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.accumulo:accumulo-shell. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34340 in the wild and no public exploit code.","fix":"Upgrade org.apache.accumulo:accumulo-shell to 2.1.1 or later.","what":"CVE-2023-34340 is a critical authentication bypass vulnerability in Apache Accumulo, published on 21 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-34340 and fix it if it is affected.\n\nWhat it is: CVE-2023-34340 is a critical authentication bypass vulnerability in Apache Accumulo, published on 21 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-34340 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.accumulo:accumulo-shell (Maven): affected from 2.1.0; fixed in 2.1.1\n- org.apache.accumulo:accumulo-shell (Maven): affected from 2.1.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34340/ (Markdown: https://insights.sbomify.com/CVE-2023-34340/index.md)","id":"CVE-2023-34340","markdown":"https://insights.sbomify.com/CVE-2023-34340/index.md","name":"CVE-2023-34340","record":{"aliases":["GHSA-hp5w-w29m-vg63"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Accumulo","requires_auth":"none","summary":"Attackers can bypass authentication in Apache Accumulo by providing invalid credentials due to improper validation of cached credentials.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"accumulo","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Improper Authentication vulnerability in Apache Software Foundation Apache Accumulo.\nThis issue affects Apache Accumulo: 2.1.0.\n\nAccumulo 2.1.0 contains a defect in the user authentication process that may succeed when invalid credentials are provided. Users are advised to upgrade to 2.1.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Accumulo: Accumulo 2.1.0 may incorrectly validate cached credentials","id":"CVE-2023-34340","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in MegaRAC SPx","id":"CVE-2023-34341"},"packages":[{"ecosystem":"Maven","fixed":["2.1.1"],"introduced":["2.1.0"],"last_affected":[],"package":"org.apache.accumulo:accumulo-shell","purl":null,"source":"GHSA-hp5w-w29m-vg63"},{"ecosystem":"Maven","fixed":["2.1.1"],"introduced":["2.1.0"],"last_affected":[],"package":"org.apache.accumulo:accumulo-shell","purl":"pkg:maven/org.apache.accumulo/accumulo-shell","source":"GHSA-hp5w-w29m-vg63"}],"prev":{"headline":"Information disclosure in Ktor","id":"CVE-2023-34339"},"products":["Apache Accumulo"],"published":"2023-06-21","related":[{"cvss_score":8.1,"headline":"Apache Accumulo Improper Handling of Insufficient Permissions","id":"CVE-2020-17533","kev_date_added":null,"published":"2020-12-29"},{"cvss_score":5.7,"headline":"Apache Accumulo: A user can trigger a graceful shutdown of services without the relevant system permissions","id":"CVE-2026-62764","kev_date_added":null,"published":"2026-07-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-09","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass authentication in Apache Accumulo by providing invalid credentials due to improper validation of cached credentials.","url":"https://insights.sbomify.com/CVE-2023-34340/"}