# CVE-2023-34340: Apache Accumulo: Accumulo 2.1.0 may incorrectly validate cached credentials

> Attackers can bypass authentication in Apache Accumulo by providing invalid credentials due to improper validation of cached credentials.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jun 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-hp5w-w29m-vg63

## What is CVE-2023-34340?

CVE-2023-34340 is a critical authentication bypass vulnerability in Apache Accumulo, published on 21 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Authentication vulnerability in Apache Software Foundation Apache Accumulo.
This issue affects Apache Accumulo: 2.1.0.

Accumulo 2.1.0 contains a defect in the user authentication process that may succeed when invalid credentials are provided. Users are advised to upgrade to 2.1.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-34340?

2 open source packages ship an affected version, including org.apache.accumulo:accumulo-shell. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.accumulo:accumulo-shell` | Maven | From 2.1.0 | 2.1.1 |
| `org.apache.accumulo:accumulo-shell` | Maven | From 2.1.0 | 2.1.1 |

Products: Apache Accumulo.

## How do I fix CVE-2023-34340?

Upgrade org.apache.accumulo:accumulo-shell to 2.1.1 or later.

## Is CVE-2023-34340 being exploited?

There is no known exploitation of CVE-2023-34340 in the wild and no public exploit code.

## Other vulnerabilities in Apache Accumulo

- [CVE-2020-17533](https://insights.sbomify.com/CVE-2020-17533/): Apache Accumulo Improper Handling of Insufficient Permissions (high 8.1)
- [CVE-2026-62764](https://insights.sbomify.com/CVE-2026-62764/): Apache Accumulo: A user can trigger a graceful shutdown of services without the relevant system permissions (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34340 and fix it if it is affected.

What it is: CVE-2023-34340 is a critical authentication bypass vulnerability in Apache Accumulo, published on 21 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34340 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.accumulo:accumulo-shell (Maven): affected from 2.1.0; fixed in 2.1.1
- org.apache.accumulo:accumulo-shell (Maven): affected from 2.1.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34340/ (Markdown: https://insights.sbomify.com/CVE-2023-34340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34340
- OSV: https://osv.dev/vulnerability/CVE-2023-34340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34340/
Summaries are generated and may contain mistakes; the official description above is the record.
