# CVE-2023-34395: Apache Airflow ODBC Provider: Remote code execution vulnerability

> Attackers can execute arbitrary code and escalate privileges by manipulating ODBC driver parameters to load malicious libraries in Apache Airflow.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jun 2023
- **Updated:** 7 Oct 2024
- **Also known as:** GHSA-9766-v29c-4vm7, PYSEC-2026-1152, ROOT-APP-PYPI-CVE-2023-34395

## What is CVE-2023-34395?

CVE-2023-34395 is a high-severity code injection vulnerability in Apache Airflow ODBC Provider, published on 27 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Argument Delimiters in a Command ('Argument Injection') vulnerability in Apache Software Foundation Apache Airflow ODBC Provider.
In OdbcHook, A privilege escalation vulnerability exists in a system due to controllable ODBC driver parameters that allow the loading of arbitrary dynamic-link libraries, resulting in command execution.
Starting version 4.0.0 driver can be set only from the hook constructor.
This issue affects Apache Airflow ODBC Provider: before 4.0.0.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2023-34395?

3 open source packages ship an affected version, including apache-airflow-providers-odbc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-odbc` | PyPI | All versions | 4.0.0 |
| `apache-airflow-providers-odbc` | PyPI | All versions | 4.0.0 |
| `apache-airflow-providers-odbc` | PyPI | All versions | 4.0.0 |

Products: Apache Apache-Airflow-Providers-Odbc.

## How do I fix CVE-2023-34395?

Upgrade apache-airflow-providers-odbc to 4.0.0 or later.

## Is CVE-2023-34395 being exploited?

There is no known exploitation of CVE-2023-34395 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34395 and fix it if it is affected.

What it is: CVE-2023-34395 is a high-severity code injection vulnerability in Apache Airflow ODBC Provider, published on 27 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-34395 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-odbc (PyPI): affected all versions; fixed in 4.0.0
- apache-airflow-providers-odbc (PyPI): affected all versions; fixed in 4.0.0
- apache-airflow-providers-odbc (PyPI): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34395/ (Markdown: https://insights.sbomify.com/CVE-2023-34395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34395
- OSV: https://osv.dev/vulnerability/CVE-2023-34395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34395/
Summaries are generated and may contain mistakes; the official description above is the record.
