CVE-2023-34396 Apache Struts: DoS via OOM owing to no sanity limit on normal form fields in multipart forms
Attackers can cause denial of service via memory exhaustion by sending multipart forms with unlimited normal fields in Apache Struts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-34396?
CVE-2023-34396 is a medium-severity denial of service vulnerability in Apache Struts, published on 14 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Software Foundation Apache Struts.This issue affects Apache Struts: through 2.5.30, through 6.1.2.
Upgrade to Struts 2.5.31 or 6.1.2.1 or greater
Weakness: CWE-770
Which versions are affected by CVE-2023-34396?
8 open source packages ship an affected version, including org.apache.struts:struts2-core, org.apache.struts:struts-core and struts:struts. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | All versions | 2.5.31 |
org.apache.struts:struts2-core Maven | All versions | 2.5.31 |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.1.2.1 |
org.apache.struts:struts2-core Maven | From 6.0.0 | 6.1.2.1 |
org.apache.struts:struts-core Maven | All versions to 1.3.10 | None |
org.apache.struts:struts-core Maven | All versions to 1.3.10 | None |
2 more packages
struts:struts Maven | All versions to 1.2.9 | None |
struts:struts Maven | All versions to 1.2.9 | None |
Products include Apache Struts.
How do I fix CVE-2023-34396?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.5.31 or 6.1.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-34396 being exploited?
There is no known exploitation of CVE-2023-34396 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-4g42-gqrg-4633.