# CVE-2023-34408: Cross-site scripting in n/a

> Attackers can inject malicious scripts via RSS titles in DokuWiki, potentially executing code in user browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Jun 2023
- **Updated:** 8 Jan 2025
- **Also known as:** BIT-dokuwiki-2023-34408, DEBIAN-CVE-2023-34408, GHSA-q47f-4whr-chq6, UBUNTU-CVE-2023-34408

## What is CVE-2023-34408?

CVE-2023-34408 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

DokuWiki before 2023-04-04a allows XSS via RSS titles.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-34408?

1 open source package ship an affected version, including dokuwiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dokuwiki` | Bitnami | All versions | 20240206.1.0 |

Products: Dokuwiki Dokuwiki.

## How do I fix CVE-2023-34408?

Upgrade dokuwiki to 20240206.1.0 or later.

## Is CVE-2023-34408 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34408 exists.

## Other vulnerabilities in n/a

- [CVE-2018-15474](https://insights.sbomify.com/CVE-2018-15474/): Code injection in n/a (critical 9.6)
- [CVE-2009-1960](https://insights.sbomify.com/CVE-2009-1960/): Code injection in n/a (critical 9.3)
- [CVE-2016-7964](https://insights.sbomify.com/CVE-2016-7964/): Server-side request forgery in n/a (high 8.6)
- [CVE-2010-0288](https://insights.sbomify.com/CVE-2010-0288/): Missing authorization in n/a (high 7.5)
- [CVE-2019-25338](https://insights.sbomify.com/CVE-2019-25338/): Dokuwiki 2018-04-22b - Username Enumeration (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34408 and fix it if it is affected.

What it is: CVE-2023-34408 is a medium-severity cross-site scripting vulnerability in n/a, published on 5 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34408 exists.

Affected packages and fixed versions:
- dokuwiki (Bitnami): affected all versions; fixed in 20240206.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34408/ (Markdown: https://insights.sbomify.com/CVE-2023-34408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34408
- OSV: https://osv.dev/vulnerability/CVE-2023-34408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34408/
Summaries are generated and may contain mistakes; the official description above is the record.
