{"answers":{"affected":"1 open source package ship an affected version, including gitlab. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3441 exists.","fix":"Upgrade gitlab to 16.4.0 or later.","what":"CVE-2023-3441 is a medium-severity vulnerability in Gitlab Gitlab, published on 1 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-3441 and fix it if it is affected.\n\nWhat it is: CVE-2023-3441 is a medium-severity vulnerability in Gitlab Gitlab, published on 1 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3441 exists.\n\nAffected packages and fixed versions:\n- gitlab (Bitnami): affected from 8.0.0; fixed in 16.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-3441/ (Markdown: https://insights.sbomify.com/CVE-2023-3441/index.md)","id":"CVE-2023-3441","markdown":"https://insights.sbomify.com/CVE-2023-3441/index.md","name":"CVE-2023-3441","record":{"aliases":["BIT-gitlab-2023-3441","GHSA-j2mx-xc3v-gw3q","UBUNTU-CVE-2023-3441"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"GitLab","requires_auth":"high_privilege","summary":"GitLab fails to adequately warn users about security risks when granting merge rights to protected branches, potentially exposing sensitive information.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitLab","cpe":[{"product":"gitlab","vendor":"gitlab"}],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-213","name":"Exposure of Sensitive Information Due to Incompatible Policies"}],"description":"An issue has been discovered in GitLab EE/CE affecting all versions starting from 8.0 before 16.4. The product did not sufficiently warn about security implications of granting merge rights to protected branches.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Exposure of Sensitive Information Due to Incompatible Policies in GitLab","id":"CVE-2023-3441","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"gitlab:gitlab","products":["gitlab:gitlab"],"type":"information_disclosure","year":"2023"},"n_packages":1,"n_references":4,"next":{"headline":"Missing Authorization in Jenkins plug-in for ServiceNow DevOps","id":"CVE-2023-3442"},"packages":[{"ecosystem":"Bitnami","fixed":["16.4.0"],"introduced":["8.0.0"],"last_affected":[],"package":"gitlab","purl":"pkg:bitnami/gitlab","source":"BIT-gitlab-2023-3441"}],"prev":{"headline":"File and Directory Permission Vulnerability in JP1/Performance Management","id":"CVE-2023-3440"},"products":["GitLab"],"published":"2024-10-01","related":[{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound","id":"CVE-2026-97229","kev_date_added":"2026-10-29","published":"2026-10-13"},{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Path Traversal","id":"CVE-2026-85706","kev_date_added":"2026-09-11","published":"2026-09-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Improper Access Control","id":"CVE-2023-7028","kev_date_added":"2024-05-01","published":"2024-01-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Remote Code Execution","id":"CVE-2021-22205","kev_date_added":"2021-11-03","published":"2021-04-23"},{"cvss_score":6.8,"headline":"GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)","id":"CVE-2021-39935","kev_date_added":"2026-02-03","published":"2021-12-13"},{"cvss_score":6.8,"headline":"GitLab Server-Side Request Forgery (SSRF)","id":"CVE-2021-22175","kev_date_added":"2026-02-18","published":"2021-06-11"},{"cvss_score":10,"headline":"Integer Overflow or Wraparound in GitLab","id":"CVE-2026-110264","kev_date_added":null,"published":"2026-10-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-01","vendors":["GitLab"]},"summary":"GitLab fails to adequately warn users about security risks when granting merge rights to protected branches, potentially exposing sensitive information.","url":"https://insights.sbomify.com/CVE-2023-3441/"}