# CVE-2023-34411: xml-rs vulnerable to denial of service via invalid token in XML document

> An attacker can cause a denial of service via a panic in the xml-rs crate by submitting a malformed XML document with invalid tokens.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2023
- **Updated:** 8 Jan 2025
- **Also known as:** GHSA-7gf7-jv65-wjmh, UBUNTU-CVE-2023-34411

## What is CVE-2023-34411?

CVE-2023-34411 is a high-severity denial of service vulnerability in n/a, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The xml-rs crate before 0.8.14 for Rust and Crab allows a denial of service (panic) via an invalid <! token (such as <!DOCTYPEs/%<!A nesting) in an XML document. The earliest affected version is 0.8.9.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2023-34411?

2 open source packages ship an affected version, including xml-rs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xml-rs` | crates.io | From 0.8.9 | 0.8.14 |
| `xml-rs` | crates.io | From 0.8.9 | 0.8.14 |

Products: Xml Library Project Xml Library.

## How do I fix CVE-2023-34411?

Upgrade xml-rs to 0.8.14 or later.

## Is CVE-2023-34411 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34411 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34411 and fix it if it is affected.

What it is: CVE-2023-34411 is a high-severity denial of service vulnerability in n/a, published on 5 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34411 exists.

Affected packages and fixed versions:
- xml-rs (crates.io): affected from 0.8.9; fixed in 0.8.14
- xml-rs (crates.io): affected from 0.8.9; fixed in 0.8.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34411/ (Markdown: https://insights.sbomify.com/CVE-2023-34411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34411
- OSV: https://osv.dev/vulnerability/CVE-2023-34411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34411/
Summaries are generated and may contain mistakes; the official description above is the record.
