{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:servicenow-devops. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-3442 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:servicenow-devops to 1.38.1 or later.","what":"CVE-2023-3442 is a high-severity missing authorization vulnerability in Jenkins plug-in for ServiceNow DevOps, published on 26 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-3442 and fix it if it is affected.\n\nWhat it is: CVE-2023-3442 is a high-severity missing authorization vulnerability in Jenkins plug-in for ServiceNow DevOps, published on 26 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-3442 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:servicenow-devops (Maven): affected all versions; fixed in 1.38.1\n- io.jenkins.plugins:servicenow-devops (Maven): affected all versions; fixed in 1.38.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-3442/ (Markdown: https://insights.sbomify.com/CVE-2023-3442/index.md)","id":"CVE-2023-3442","markdown":"https://insights.sbomify.com/CVE-2023-3442/index.md","name":"CVE-2023-3442","record":{"aliases":["GHSA-cj2x-r74q-vcx9"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins ServiceNow plugin","requires_auth":"low_privilege","summary":"Attackers can access sensitive information due to missing authorization checks in the Jenkins ServiceNow DevOps plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"SN","cpe":[{"product":"servicenow_devops","vendor":"jenkins"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"A missing authorization vulnerability exists in versions of the Jenkins Plug-in for ServiceNow DevOps prior to 1.38.1 that, if exploited successfully, could cause the unwanted exposure of sensitive information. To address this issue, apply the 1.38.1 version of the Jenkins plug-in for ServiceNow DevOps on your Jenkins server.  No changes are required on your instances of the Now Platform.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing Authorization in Jenkins plug-in for ServiceNow DevOps","id":"CVE-2023-3442","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Incorrect Authorization in GitLab","id":"CVE-2023-3443"},"packages":[{"ecosystem":"Maven","fixed":["1.38.1"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:servicenow-devops","purl":null,"source":"GHSA-cj2x-r74q-vcx9"},{"ecosystem":"Maven","fixed":["1.38.1"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:servicenow-devops","purl":"pkg:maven/io.jenkins.plugins/servicenow-devops","source":"GHSA-cj2x-r74q-vcx9"}],"prev":{"headline":"Exposure of Sensitive Information Due to Incompatible Policies in GitLab","id":"CVE-2023-3441"},"products":["Jenkins plug-in for ServiceNow DevOps"],"published":"2023-07-26","related":[{"cvss_score":6.1,"headline":"Cross-Site Request Forgery (CSRF) in Jenkins Plug-in for ServiceNow DevOps","id":"CVE-2023-3414","kev_date_added":null,"published":"2023-07-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-15","vendors":["ServiceNow"]},"summary":"Attackers can access sensitive information due to missing authorization checks in the Jenkins ServiceNow DevOps plugin.","url":"https://insights.sbomify.com/CVE-2023-3442/"}