# CVE-2023-3442: Missing Authorization in Jenkins plug-in for ServiceNow DevOps

> Attackers can access sensitive information due to missing authorization checks in the Jenkins ServiceNow DevOps plugin.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2023
- **Updated:** 15 Oct 2024
- **Also known as:** GHSA-cj2x-r74q-vcx9

## What is CVE-2023-3442?

CVE-2023-3442 is a high-severity missing authorization vulnerability in Jenkins plug-in for ServiceNow DevOps, published on 26 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing authorization vulnerability exists in versions of the Jenkins Plug-in for ServiceNow DevOps prior to 1.38.1 that, if exploited successfully, could cause the unwanted exposure of sensitive information. To address this issue, apply the 1.38.1 version of the Jenkins plug-in for ServiceNow DevOps on your Jenkins server.  No changes are required on your instances of the Now Platform.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-3442?

2 open source packages ship an affected version, including io.jenkins.plugins:servicenow-devops. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:servicenow-devops` | Maven | All versions | 1.38.1 |
| `io.jenkins.plugins:servicenow-devops` | Maven | All versions | 1.38.1 |

Products: Jenkins Servicenow Devops.

## How do I fix CVE-2023-3442?

Upgrade io.jenkins.plugins:servicenow-devops to 1.38.1 or later.

## Is CVE-2023-3442 being exploited?

There is no known exploitation of CVE-2023-3442 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins plug-in for ServiceNow DevOps

- [CVE-2023-3414](https://insights.sbomify.com/CVE-2023-3414/): Cross-Site Request Forgery (CSRF) in Jenkins Plug-in for ServiceNow DevOps (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3442 and fix it if it is affected.

What it is: CVE-2023-3442 is a high-severity missing authorization vulnerability in Jenkins plug-in for ServiceNow DevOps, published on 26 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-3442 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:servicenow-devops (Maven): affected all versions; fixed in 1.38.1
- io.jenkins.plugins:servicenow-devops (Maven): affected all versions; fixed in 1.38.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3442/ (Markdown: https://insights.sbomify.com/CVE-2023-3442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3442
- OSV: https://osv.dev/vulnerability/CVE-2023-3442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3442/
Summaries are generated and may contain mistakes; the official description above is the record.
