CVE-2023-3444 Incorrect Authorization in GitLab

Medium 5.7 Published Updated

An attacker can bypass authorization controls to merge arbitrary code into protected branches in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-3444?

CVE-2023-3444 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.3 before 15.11.10, all versions starting from 16.0 before 16.0.6, all versions starting from 16.1 before 16.1.1, which allows an attacker to merge arbitrary code into protected branches.

Weakness: CWE-863

Which versions are affected by CVE-2023-3444?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.3.015.11.10, 16.0.6, 16.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2023-3444?

Upgrade gitlab to a fixed version for your release line: 15.11.10, 16.0.6 or 16.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-3444 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-3444 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3444, GHSA-qccj-j742-ww2r, UBUNTU-CVE-2023-3444.

Is CVE-2023-3444 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free