# CVE-2023-34442: Apache Camel JIRA: Temporary file information disclosure in Camel-Jira

> Attackers can access sensitive temporary file information in Apache Camel JIRA components, requiring an upgrade to patched versions.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2023
- **Updated:** 7 Oct 2024
- **Also known as:** GHSA-6g2w-257v-3c9f

## What is CVE-2023-34442?

CVE-2023-34442 is a low-severity vulnerability in Apache Camel, published on 10 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Software Foundation Apache Camel.This issue affects Apache Camel: from 3.X through <=3.14.8, from 3.18.X through <=3.18.7, from 3.20.X through <= 3.20.5, from 4.X through <= 4.0.0-M3.

Users should upgrade to 3.14.9, 3.18.8, 3.20.6 or 3.21.0 and for users on Camel 4.x update to 4.0.0-M1

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-34442?

8 open source packages ship an affected version, including org.apache.camel:camel-jira. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-jira` | Maven | From 3.0.0-M3 | 3.14.9 |
| `org.apache.camel:camel-jira` | Maven | From 3.0.0-M3 | 3.14.9 |
| `org.apache.camel:camel-jira` | Maven | From 3.15.0 | 3.18.8 |
| `org.apache.camel:camel-jira` | Maven | From 3.15.0 | 3.18.8 |
| `org.apache.camel:camel-jira` | Maven | From 3.20.0 | 3.20.6 |
| `org.apache.camel:camel-jira` | Maven | From 3.20.0 | 3.20.6 |
| `org.apache.camel:camel-jira` | Maven | From 4.0.0-M1 | 4.0.0-RC1 |
| `org.apache.camel:camel-jira` | Maven | From 4.0.0-M1 | 4.0.0-RC1 |

Products: Apache Camel.

## How do I fix CVE-2023-34442?

Upgrade org.apache.camel:camel-jira to a fixed version for your release line: 3.14.9, 3.18.8, 3.20.6 or 4.0.0-RC1.

## Is CVE-2023-34442 being exploited?

There is no known exploitation of CVE-2023-34442 in the wild and no public exploit code.

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34442 and fix it if it is affected.

What it is: CVE-2023-34442 is a low-severity vulnerability in Apache Camel, published on 10 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34442 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-jira (Maven): affected from 3.0.0-M3; fixed in 3.14.9
- org.apache.camel:camel-jira (Maven): affected from 3.0.0-M3; fixed in 3.14.9
- org.apache.camel:camel-jira (Maven): affected from 3.15.0; fixed in 3.18.8
- org.apache.camel:camel-jira (Maven): affected from 3.15.0; fixed in 3.18.8
- org.apache.camel:camel-jira (Maven): affected from 3.20.0; fixed in 3.20.6
- org.apache.camel:camel-jira (Maven): affected from 3.20.0; fixed in 3.20.6
- org.apache.camel:camel-jira (Maven): affected from 4.0.0-M1; fixed in 4.0.0-RC1
- org.apache.camel:camel-jira (Maven): affected from 4.0.0-M1; fixed in 4.0.0-RC1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34442/ (Markdown: https://insights.sbomify.com/CVE-2023-34442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34442
- OSV: https://osv.dev/vulnerability/CVE-2023-34442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34442/
Summaries are generated and may contain mistakes; the official description above is the record.
