CVE-2023-34446 iTop XSS vulnerability on pages/preferences.php
Cross-site scripting in iTop preferences page allows attackers to execute scripts in victim browsers, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2023-34446?
CVE-2023-34446 is a high-severity cross-site scripting vulnerability in Combodo Itop, published on 25 Oct 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
iTop is an open source, web-based IT service management platform. Prior to versions 3.0.4 and 3.1.0, when displaying `pages/preferences.php`, cross site scripting is possible. This issue is fixed in versions 3.0.4 and 3.1.0.
Weakness: CWE-79
Which versions are affected by CVE-2023-34446?
It affects 1 product.
Products include Combodo Itop.
How do I fix CVE-2023-34446?
No fix has been published for CVE-2023-34446 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-34446 being exploited?
There is no known exploitation of CVE-2023-34446 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Combodo Itop
- CVE-2023-48710 iTop limit pages/exec.php script to PHP files
- CVE-2022-39214 Authenticated users of Combodo iTop can take over any account
- CVE-2021-41161 XSS in csvimport in 3.0.0-beta versions
- CVE-2021-41162 Cross-site Scripting in Combodo iTop
- CVE-2025-47773 Combodo iTop has XSS vulnerability in /pages/ajax.render.php
Sources
Also known as GHSA-q4pp-j46r-gm68.