# CVE-2023-34448: Grav Server-side Template Injection (SSTI) via Twig Default Filters

> An attacker can achieve remote code execution in Grav CMS by exploiting server-side template injection via Twig built-in filters.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2023
- **Updated:** 18 Dec 2024
- **Also known as:** GHSA-whr7-m3f8-mpm8

## What is CVE-2023-34448?

CVE-2023-34448 is a high-severity code injection vulnerability in Getgrav Grav, published on 14 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is a flat-file content management system. Prior to version 1.7.42, the patch for CVE-2022-2073, a server-side template injection vulnerability in Grav leveraging the default `filter()` function, did not block other built-in functions exposed by Twig's Core Extension that could be used to invoke arbitrary unsafe functions, thereby allowing for remote code execution. A patch in version 1.74.2 overrides the built-in Twig `map()` and `reduce()` filter functions in `system/src/Grav/Common/Twig/Extension/GravExtension.php` to validate the argument passed to the filter in `$arrow`.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2023-34448?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.42 |
| `getgrav/grav` | Packagist | All versions | 1.7.42 |

Products: Getgrav Grav.

## How do I fix CVE-2023-34448?

Upgrade getgrav/grav to 1.7.42 or later.

## Is CVE-2023-34448 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34448 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34448 and fix it if it is affected.

What it is: CVE-2023-34448 is a high-severity code injection vulnerability in Getgrav Grav, published on 14 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34448 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.42
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34448/ (Markdown: https://insights.sbomify.com/CVE-2023-34448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34448
- OSV: https://osv.dev/vulnerability/CVE-2023-34448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34448/
Summaries are generated and may contain mistakes; the official description above is the record.
