# CVE-2023-34454: snappy-java's Integer Overflow vulnerability in compress leads to DoS

> An integer overflow in snappy-java's compress function can cause a fatal error or access violation, leading to denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2023
- **Updated:** 12 Dec 2024
- **Also known as:** CLEANSTART-2026-LZ10152, CLEANSTART-2026-PE94812, ECHO-fbe9-4d97-f7d2, GHSA-fjpj-2g6w-x25r, UBUNTU-CVE-2023-34454

## What is CVE-2023-34454?

CVE-2023-34454 is a medium-severity vulnerability in xerial snappy-java, published on 15 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

snappy-java is a fast compressor/decompressor for Java. Due to unchecked multiplications, an integer overflow may occur in versions prior to 1.1.10.1, causing an unrecoverable fatal error.

The function `compress(char[] input)` in the file `Snappy.java` receives an array of characters and compresses it. It does so by multiplying the length by 2 and passing it to the rawCompress` function.

Since the length is not tested, the multiplication by two can cause an integer overflow and become negative. The rawCompress function then uses the received length and passes it to the natively compiled maxCompressedLength function, using the returned value to allocate a byte array.

Since the maxCompressedLength function treats the length as an unsigned integer, it doesn’t care that it is negative, and it returns a valid value, which is casted to a signed integer by the Java engine. If the result is negative, a `java.lang.NegativeArraySizeException` exception will be raised while trying to allocate the array `buf`. On the other side, if the result is positive, the `buf` array will successfully be allocated, but its size might be too small to use for the compression, causing a fatal Access Violation error.

The same issue exists also when using the `compress` functions that receive double, float, int, long and short, each using a different multiplier that may cause the same issue. The issue most likely won’t occur when using a byte array, since creating a byte array of size 0x80000000 (or any other negative value) is impossible in the first place.

Version 1.1.10.1 contains a patch for this issue.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2023-34454?

2 open source packages ship an affected version, including org.xerial.snappy:snappy-java. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.1 |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.1 |

Products: Xerial Snappy-Java.

## How do I fix CVE-2023-34454?

Upgrade org.xerial.snappy:snappy-java to 1.1.10.1 or later.

## Is CVE-2023-34454 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34454 exists.

## Other vulnerabilities in xerial snappy-java

- [CVE-2023-43642](https://insights.sbomify.com/CVE-2023-43642/): Missing upper bound check on chunk length in snappy-java (high 7.5)
- [CVE-2023-34455](https://insights.sbomify.com/CVE-2023-34455/): snappy-java's unchecked chunk length leads to DoS (high 7.5)
- [CVE-2023-34453](https://insights.sbomify.com/CVE-2023-34453/): snappy-java's Integer Overflow vulnerability in shuffle leads to DoS (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34454 and fix it if it is affected.

What it is: CVE-2023-34454 is a medium-severity vulnerability in xerial snappy-java, published on 15 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34454 exists.

Affected packages and fixed versions:
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.1
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34454/ (Markdown: https://insights.sbomify.com/CVE-2023-34454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34454
- OSV: https://osv.dev/vulnerability/CVE-2023-34454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34454/
Summaries are generated and may contain mistakes; the official description above is the record.
