# CVE-2023-34455: snappy-java's unchecked chunk length leads to DoS

> Attackers can cause denial of service in snappy-java by providing crafted input that triggers memory exhaustion or fatal errors.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2023
- **Updated:** 13 Feb 2025
- **Also known as:** CLEANSTART-2026-EQ18594, CLEANSTART-2026-NF97510, CLSA-2026-1774743847, ECHO-49bc-da78-64e7, GHSA-qcwq-55hx-v3vh, ROOT-APP-MAVEN-CVE-2023-34455, UBUNTU-CVE-2023-34455

## What is CVE-2023-34455?

CVE-2023-34455 is a high-severity denial of service vulnerability in xerial snappy-java, published on 15 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

snappy-java is a fast compressor/decompressor for Java. Due to use of an unchecked chunk length, an unrecoverable fatal error can occur in versions prior to 1.1.10.1.

The code in the function hasNextChunk in the fileSnappyInputStream.java checks if a given stream has more chunks to read. It does that by attempting to read 4 bytes. If it wasn’t possible to read the 4 bytes, the function returns false. Otherwise, if 4 bytes were available, the code treats them as the length of the next chunk.

In the case that the `compressed` variable is null, a byte array is allocated with the size given by the input data. Since the code doesn’t test the legality of the `chunkSize` variable, it is possible to pass a negative number (such as 0xFFFFFFFF which is -1), which will cause the code to raise a `java.lang.NegativeArraySizeException` exception. A worse case would happen when passing a huge positive value (such as 0x7FFFFFFF), which would raise the fatal `java.lang.OutOfMemoryError` error.

Version 1.1.10.1 contains a patch for this issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-34455?

2 open source packages ship an affected version, including org.xerial.snappy:snappy-java. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.1 |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.1 |

Products: Xerial Snappy-Java.

## How do I fix CVE-2023-34455?

Upgrade org.xerial.snappy:snappy-java to 1.1.10.1 or later.

## Is CVE-2023-34455 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34455 exists.

## Other vulnerabilities in xerial snappy-java

- [CVE-2023-43642](https://insights.sbomify.com/CVE-2023-43642/): Missing upper bound check on chunk length in snappy-java (high 7.5)
- [CVE-2023-34453](https://insights.sbomify.com/CVE-2023-34453/): snappy-java's Integer Overflow vulnerability in shuffle leads to DoS (medium 5.9)
- [CVE-2023-34454](https://insights.sbomify.com/CVE-2023-34454/): snappy-java's Integer Overflow vulnerability in compress leads to DoS (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34455 and fix it if it is affected.

What it is: CVE-2023-34455 is a high-severity denial of service vulnerability in xerial snappy-java, published on 15 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34455 exists.

Affected packages and fixed versions:
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.1
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34455/ (Markdown: https://insights.sbomify.com/CVE-2023-34455/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34455
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34455
- OSV: https://osv.dev/vulnerability/CVE-2023-34455

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34455/
Summaries are generated and may contain mistakes; the official description above is the record.
