# CVE-2023-34459: OpenZeppelin Contracts's MerkleProof multiproofs may allow proving arbitrary leaves for specific trees

> Attackers can forge valid Merkle multiproofs for specific tree structures, allowing unauthorized state changes in smart contracts using affected OpenZeppelin functions.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2023
- **Updated:** 16 Dec 2024
- **Also known as:** GHSA-wprv-93r4-jj2p

## What is CVE-2023-34459?

CVE-2023-34459 is a medium-severity vulnerability in openzeppelin-contracts, published on 16 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for smart contract development. Starting in version 4.7.0 and prior to version 4.9.2, when the `verifyMultiProof`, `verifyMultiProofCalldata`, `procesprocessMultiProof`, or `processMultiProofCalldat` functions are in use, it is possible to construct merkle trees that allow forging a valid multiproof for an arbitrary set of leaves.

A contract may be vulnerable if it uses multiproofs for verification and the merkle tree that is processed includes a node with value 0 at depth 1 (just under the root). This could happen inadvertedly for balanced trees with 3 leaves or less, if the leaves are not hashed. This could happen deliberately if a malicious tree builder includes such a node in the tree.

A contract is not vulnerable if it uses single-leaf proving (`verify`, `verifyCalldata`, `processProof`, or `processProofCalldata`), or if it uses multiproofs with a known tree that has hashed leaves. Standard merkle trees produced or validated with the @openzeppelin/merkle-tree library are safe.

The problem has been patched in version 4.9.2.

Some workarounds are available. For those using multiproofs: When constructing merkle trees hash the leaves and do not insert empty nodes in your trees. Using the @openzeppelin/merkle-tree package eliminates this issue. Do not accept user-provided merkle roots without reconstructing at least the first level of the tree. Verify the merkle tree structure by reconstructing it from the leaves.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2023-34459?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.7.0 | 4.9.2 |
| `@openzeppelin/contracts` | npm | From 4.7.0 | 4.9.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.7.0 | 4.9.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.7.0 | 4.9.2 |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

## How do I fix CVE-2023-34459?

Upgrade @openzeppelin/contracts to 4.9.2 or later.

## Is CVE-2023-34459 being exploited?

There is no known exploitation of CVE-2023-34459 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34459 and fix it if it is affected.

What it is: CVE-2023-34459 is a medium-severity vulnerability in openzeppelin-contracts, published on 16 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-34459 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.7.0; fixed in 4.9.2
- @openzeppelin/contracts (npm): affected from 4.7.0; fixed in 4.9.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.7.0; fixed in 4.9.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.7.0; fixed in 4.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34459/ (Markdown: https://insights.sbomify.com/CVE-2023-34459/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34459
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34459
- OSV: https://osv.dev/vulnerability/CVE-2023-34459

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34459/
Summaries are generated and may contain mistakes; the official description above is the record.
