CVE-2023-34462 netty-handler SniHandler 16MB allocation

Medium 6.5 Published Updated

Attackers can cause excessive memory allocation in Netty's SniHandler during TLS handshakes, leading to denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-34462?

CVE-2023-34462 is a medium-severity denial of service vulnerability in Netty Netty, published on 22 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. The `SniHandler` can allocate up to 16MB of heap for each channel during the TLS handshake. When the handler or the channel does not have an idle timeout, it can be used to make a TCP server using the `SniHandler` to allocate 16MB of heap. The `SniHandler` class is a handler that waits for the TLS handshake to configure a `SslHandler` according to the indicated server name by the `ClientHello` record. For this matter it allocates a `ByteBuf` using the value defined in the `ClientHello` record. Normally the value of the packet should be smaller than the handshake packet but there are not checks done here and the way the code is written, it is possible to craft a packet that makes the `SslClientHelloHandler`. This vulnerability has been fixed in version 4.1.94.Final.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2023-34462?

2 open source packages ship an affected version, including io.netty:netty-handler. It affects 1 product.

PackageAffectedFixed in
io.netty:netty-handler MavenAll versions4.1.94.Final
io.netty:netty-handler MavenAll versions4.1.94.Final
Linux distribution packages (8)
netty-tcnative SUSE:Linux Enterprise Module for Development Tools 15 SP4All versions2.0.61-150200.3.13.1
netty-tcnative SUSE:Linux Enterprise Module for Development Tools 15 SP5All versions2.0.61-150200.3.13.1
netty SUSE:Linux Enterprise Module for Package Hub 15 SP5All versions4.1.94-150200.4.17.1
netty-tcnative SUSE:Linux Enterprise Real Time 15 SP3All versions2.0.61-150200.3.13.1
netty openSUSE:Leap 15.4All versions4.1.94-150200.4.17.1
netty-tcnative openSUSE:Leap 15.4All versions2.0.61-150200.3.13.1
netty openSUSE:Leap 15.5All versions4.1.94-150200.4.17.1
netty-tcnative openSUSE:Leap 15.5All versions2.0.61-150200.3.13.1

Products include Netty Netty.

How do I fix CVE-2023-34462?

Upgrade io.netty:netty-handler to 4.1.94.Final or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-34462 being exploited?

There is no known exploitation of CVE-2023-34462 in the wild and no public exploit code.

All Netty Netty vulnerabilities

Sources

Also known as CLEANSTART-2026-IQ25144, CLEANSTART-2026-JJ44639, CLEANSTART-2026-SO54386, CLSA-2026-1776818207, DEBIAN-CVE-2023-34462, ECHO-271e-3fbf-886d and 6 more.

Is CVE-2023-34462 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free