# CVE-2023-34464: XWiki vulnerable to stored cross-site scripting via any wiki document and the displaycontent/rendercontent template

> Attackers can inject malicious scripts into wiki documents, potentially executing arbitrary code with victim privileges when viewed via specific templates.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2023
- **Updated:** 5 Dec 2024
- **Also known as:** GHSA-fp7h-f9f5-x4q7

## What is CVE-2023-34464?

CVE-2023-34464 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 23 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting in version 2.2.1 until versions 14.4.8, 14.10.5, and 15.1RC1 of org.xwiki.platform:xwiki-platform-web and any version prior to 14.4.8, 14.10.5, and 15.1.RC1 of org.xwiki.platform:xwiki-platform-web-templates, any user who can edit a document in a wiki like the user profile can create a stored cross-site scripting attack. The attack occurs by putting plain HTML code into that document and then tricking another user to visit that document with the `displaycontent` or `rendercontent` template and plain output syntax. If a user with programming rights is tricked into visiting such a URL, arbitrary actions be performed with this user's rights, impacting the confidentiality, integrity, and availability of the whole XWiki installation. This has been patched in XWiki 14.4.8, 14.10.5 and 15.1RC1 by setting the content type of the response to plain text when the output syntax is not an HTML syntax.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-34464?

8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates and org.xwiki.platform:xwiki-platform-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | All versions | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | All versions | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 14.5 | 14.10.5 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 14.5 | 14.10.5 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 15.0-rc-1 | 15.1-rc-1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 15.0-rc-1 | 15.1-rc-1 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 2.2.1 | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-web` | Maven | From 2.2.1 | 14.4.8 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-34464?

Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 14.4.8, 14.10.5 or 15.1-rc-1.

## Is CVE-2023-34464 being exploited?

There is no known exploitation of CVE-2023-34464 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34464 and fix it if it is affected.

What it is: CVE-2023-34464 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 23 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-34464 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected all versions; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected all versions; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 14.5; fixed in 14.10.5
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 14.5; fixed in 14.10.5
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 15.0-rc-1; fixed in 15.1-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 15.0-rc-1; fixed in 15.1-rc-1
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 2.2.1; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-web (Maven): affected from 2.2.1; fixed in 14.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34464/ (Markdown: https://insights.sbomify.com/CVE-2023-34464/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34464
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34464
- OSV: https://osv.dev/vulnerability/CVE-2023-34464

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34464/
Summaries are generated and may contain mistakes; the official description above is the record.
