CVE-2023-34465 XWiki Platform's Mail.MailConfig can be edited by any user with edit rights

Critical 10.0 Published Updated

Any logged-in user can edit mail configuration, exposing SMTP credentials and allowing modification of mail settings in XWiki Platform.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-34465?

CVE-2023-34465 is a critical missing authorization vulnerability in Xwiki Xwiki, published on 23 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

XWiki Platform is a generic wiki platform. Starting in version 11.8-rc-1 and prior to versions 14.4.8, 14.10.6, and 15.2, `Mail.MailConfig` can be edited by any logged-in user by default. Consequently, they can change the mail obfuscation configuration and view and edit the mail sending configuration, including the smtp domain name and credentials. The problem has been patched in XWiki 14.4.8, 14.10.6, and 15.1. As a workaround, the rights of the `Mail.MailConfig` page can be manually updated so that only a set of trusted users can view, edit and delete it (e.g., the `XWiki.XWikiAdminGroup` group).

Weakness: CWE-269

Which versions are affected by CVE-2023-34465?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-mail-send-default. It affects 1 product.

PackageAffectedFixed in
org.xwiki.platform:xwiki-platform-mail-send-default MavenFrom 11.8-rc-114.4.8
org.xwiki.platform:xwiki-platform-mail-send-default MavenFrom 11.8-rc-114.4.8
org.xwiki.platform:xwiki-platform-mail-send-default MavenFrom 14.514.10.6
org.xwiki.platform:xwiki-platform-mail-send-default MavenFrom 14.514.10.6
org.xwiki.platform:xwiki-platform-mail-send-default MavenFrom 15.0-rc-115.1
org.xwiki.platform:xwiki-platform-mail-send-default MavenFrom 15.0-rc-115.1

Products include Xwiki Xwiki.

How do I fix CVE-2023-34465?

Upgrade org.xwiki.platform:xwiki-platform-mail-send-default to a fixed version for your release line: 14.4.8, 14.10.6 or 15.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-34465 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34465 exists.

All Xwiki Xwiki vulnerabilities

Sources

Also known as GHSA-g75c-cjr6-39mc.

Is CVE-2023-34465 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free