# CVE-2023-34465: XWiki Platform's Mail.MailConfig can be edited by any user with edit rights

> Any logged-in user can edit mail configuration, exposing SMTP credentials and allowing modification of mail settings in XWiki Platform.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2023
- **Updated:** 29 Nov 2024
- **Also known as:** GHSA-g75c-cjr6-39mc

## What is CVE-2023-34465?

CVE-2023-34465 is a critical missing authorization vulnerability in Xwiki Xwiki, published on 23 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 11.8-rc-1 and prior to versions 14.4.8, 14.10.6, and 15.2, `Mail.MailConfig` can be edited by any logged-in user by default. Consequently, they can change the mail obfuscation configuration and view and edit the mail sending configuration, including the smtp domain name and credentials. The problem has been patched in XWiki 14.4.8, 14.10.6, and 15.1. As a workaround, the rights of the `Mail.MailConfig` page can be manually updated so that only a set of trusted users can view, edit and delete it (e.g., the `XWiki.XWikiAdminGroup` group).

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-34465?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-mail-send-default. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-mail-send-default` | Maven | From 11.8-rc-1 | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-mail-send-default` | Maven | From 11.8-rc-1 | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-mail-send-default` | Maven | From 14.5 | 14.10.6 |
| `org.xwiki.platform:xwiki-platform-mail-send-default` | Maven | From 14.5 | 14.10.6 |
| `org.xwiki.platform:xwiki-platform-mail-send-default` | Maven | From 15.0-rc-1 | 15.1 |
| `org.xwiki.platform:xwiki-platform-mail-send-default` | Maven | From 15.0-rc-1 | 15.1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-34465?

Upgrade org.xwiki.platform:xwiki-platform-mail-send-default to a fixed version for your release line: 14.4.8, 14.10.6 or 15.1.

## Is CVE-2023-34465 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34465 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34465 and fix it if it is affected.

What it is: CVE-2023-34465 is a critical missing authorization vulnerability in Xwiki Xwiki, published on 23 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34465 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-mail-send-default (Maven): affected from 11.8-rc-1; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-mail-send-default (Maven): affected from 11.8-rc-1; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-mail-send-default (Maven): affected from 14.5; fixed in 14.10.6
- org.xwiki.platform:xwiki-platform-mail-send-default (Maven): affected from 14.5; fixed in 14.10.6
- org.xwiki.platform:xwiki-platform-mail-send-default (Maven): affected from 15.0-rc-1; fixed in 15.1
- org.xwiki.platform:xwiki-platform-mail-send-default (Maven): affected from 15.0-rc-1; fixed in 15.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34465/ (Markdown: https://insights.sbomify.com/CVE-2023-34465/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34465
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34465
- OSV: https://osv.dev/vulnerability/CVE-2023-34465

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34465/
Summaries are generated and may contain mistakes; the official description above is the record.
