# CVE-2023-34466: XWiki Platform's tags on non-viewable pages can be revealed to users

> Attackers can reveal tags and infer document references of non-viewable pages in XWiki Platform, leaking sensitive information.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2023
- **Updated:** 29 Nov 2024
- **Also known as:** GHSA-7f2f-pcv3-j2r7

## What is CVE-2023-34466?

CVE-2023-34466 is a medium-severity vulnerability in Xwiki Xwiki, published on 23 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting in version 5.0-milestone-1 and prior to versions 14.4.8, 14.10.4, and 15.0-rc-1, tags from pages not viewable to the current user are leaked by the tags API. This information can also be exploited to infer the document reference of non-viewable pages. This vulnerability has been patched in XWiki 14.4.8, 14.10.4, and 15.0-rc-1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-34466?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-tag-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-tag-api` | Maven | From 14.5 | 14.10.4 |
| `org.xwiki.platform:xwiki-platform-tag-api` | Maven | From 14.5 | 14.10.4 |
| `org.xwiki.platform:xwiki-platform-tag-api` | Maven | From 5.0-milestone-1 | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-tag-api` | Maven | From 5.0-milestone-1 | 14.4.8 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-34466?

Upgrade org.xwiki.platform:xwiki-platform-tag-api to a fixed version for your release line: 14.10.4 or 14.4.8.

## Is CVE-2023-34466 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34466 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34466 and fix it if it is affected.

What it is: CVE-2023-34466 is a medium-severity vulnerability in Xwiki Xwiki, published on 23 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34466 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-tag-api (Maven): affected from 14.5; fixed in 14.10.4
- org.xwiki.platform:xwiki-platform-tag-api (Maven): affected from 14.5; fixed in 14.10.4
- org.xwiki.platform:xwiki-platform-tag-api (Maven): affected from 5.0-milestone-1; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-tag-api (Maven): affected from 5.0-milestone-1; fixed in 14.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34466/ (Markdown: https://insights.sbomify.com/CVE-2023-34466/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34466
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34466
- OSV: https://osv.dev/vulnerability/CVE-2023-34466

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34466/
Summaries are generated and may contain mistakes; the official description above is the record.
