# CVE-2023-34468: Apache NiFi: Potential Code Injection with Database Services using H2

> Authenticated users can execute arbitrary code by configuring malicious H2 database URLs in Apache NiFi connection pools.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-nifi-2023-34468, GHSA-xm2m-2q6h-22jw

## What is CVE-2023-34468?

CVE-2023-34468 is a high-severity code injection vulnerability in Apache Nifi, published on 12 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The DBCPConnectionPool and HikariCPConnectionPool Controller Services in Apache NiFi 0.0.2 through 1.21.0 allow an authenticated and authorized user to configure a Database URL with the H2 driver that enables custom code execution.

The resolution validates the Database URL and rejects H2 JDBC locations.

You are recommended to upgrade to version 1.22.0 or later which fixes this issue.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-34468?

7 open source packages ship an affected version, including org.apache.nifi:nifi-dbcp-base, nifi and org.apache.nifi:nifi-dbcp-service-nar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-dbcp-base` | Maven | From 0.0.2 | 1.22.0 |
| `org.apache.nifi:nifi-dbcp-base` | Maven | From 0.0.2 | 1.22.0 |
| `nifi` | Bitnami | From 0.0.2 | 1.22.0 |
| `org.apache.nifi:nifi-dbcp-service-nar` | Maven | From 0.0.2 | 1.22.0 |
| `org.apache.nifi:nifi-dbcp-service-nar` | Maven | From 0.0.2 | 1.22.0 |
| `org.apache.nifi:nifi-hikari-dbcp-service` | Maven | From 0.0.2 | 1.22.0 |
| `org.apache.nifi:nifi-hikari-dbcp-service` | Maven | From 0.0.2 | 1.22.0 |

Products: Apache Nifi.

## How do I fix CVE-2023-34468?

Upgrade org.apache.nifi:nifi-dbcp-base to 1.22.0 or later.

## Is CVE-2023-34468 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34468 exists.

Public exploit code:

- CVE-2023-34468: Remote Code Execution via DB Components in Apache NiFi (github_poc): https://github.com/mbadanoiu/CVE-2023-34468
- PoC exploit for CVE-2023-34468 — RCE via H2 RUNSCRIPT in Apache NiFi <= 1.21.0 (github_poc): https://github.com/sbouabid-sec/CVE-2023-34468-POC
- CVE-2023-34468 - Apache NiFi H2 RCE PoC (github_poc): https://github.com/Jeanpt/CVE-2023-34468
- Apache NiFi H2 Connection String Remote Code Execution (metasploit)
- https://github.com/shoucheng3/asf__nifi_CVE-2023-34468_1-21-00 (github_poc): https://github.com/shoucheng3/asf__nifi_CVE-2023-34468_1-21-00
- Educational proof-of-concept for CVE-2023-34468 affecting Apache NiFi. Demonstrates H2 JDBC URL abuse leading to authenticated RCE in vulnerable NiFi versions. (github_poc): https://github.com/spikeyjr/CVE-2023-34468-PoC

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34468 and fix it if it is affected.

What it is: CVE-2023-34468 is a high-severity code injection vulnerability in Apache Nifi, published on 12 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34468 exists.

Affected packages and fixed versions:
- org.apache.nifi:nifi-dbcp-base (Maven): affected from 0.0.2; fixed in 1.22.0
- org.apache.nifi:nifi-dbcp-base (Maven): affected from 0.0.2; fixed in 1.22.0
- nifi (Bitnami): affected from 0.0.2; fixed in 1.22.0
- org.apache.nifi:nifi-dbcp-service-nar (Maven): affected from 0.0.2; fixed in 1.22.0
- org.apache.nifi:nifi-dbcp-service-nar (Maven): affected from 0.0.2; fixed in 1.22.0
- org.apache.nifi:nifi-hikari-dbcp-service (Maven): affected from 0.0.2; fixed in 1.22.0
- org.apache.nifi:nifi-hikari-dbcp-service (Maven): affected from 0.0.2; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34468/ (Markdown: https://insights.sbomify.com/CVE-2023-34468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34468
- OSV: https://osv.dev/vulnerability/CVE-2023-34468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34468/
Summaries are generated and may contain mistakes; the official description above is the record.
