{"answers":{"affected":"3 open source packages ship an affected version, including langchain. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-34540 in the wild and no public exploit code.","fix":"Upgrade langchain to 0.0.225 or later.","what":"CVE-2023-34540 is a critical code injection vulnerability in n/a, published on 14 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-34540 and fix it if it is affected.\n\nWhat it is: CVE-2023-34540 is a critical code injection vulnerability in n/a, published on 14 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-34540 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- langchain (PyPI): affected all versions; fixed in 0.0.225\n- langchain (PyPI): affected all versions; fixed in 0.0.225\n- langchain (PyPI): affected all versions; fixed in 0.0.225\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-34540/ (Markdown: https://insights.sbomify.com/CVE-2023-34540/index.md)","id":"CVE-2023-34540","markdown":"https://insights.sbomify.com/CVE-2023-34540/index.md","name":"CVE-2023-34540","record":{"aliases":["GHSA-x32c-59v5-h7fg","PYSEC-2023-91"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python Langchain library","requires_auth":"none","summary":"Attackers can execute arbitrary code via crafted input in the JiraAPIWrapper component of the Langchain library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"langchain","vendor":"langchain"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Langchain before v0.0.225 was discovered to contain a remote code execution (RCE) vulnerability in the component JiraAPIWrapper (aka the JIRA API wrapper). This vulnerability allows attackers to execute arbitrary code via crafted input. As noted in the \"releases/tag\" reference, a fix is available.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Langchain OS Command Injection vulnerability","id":"CVE-2023-34540","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Langchain vulnerable to arbitrary code execution","id":"CVE-2023-34541"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.225"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":null,"source":"GHSA-x32c-59v5-h7fg"},{"ecosystem":"PyPI","fixed":["0.0.225"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":"pkg:pypi/langchain","source":"GHSA-x32c-59v5-h7fg"},{"ecosystem":"PyPI","fixed":["0.0.225"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":"pkg:pypi/langchain","source":"PYSEC-2023-91"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-34537"},"products":["n/a"],"published":"2023-06-14","related":[{"cvss_score":9.8,"headline":"Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library","id":"CVE-2023-39631","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36281","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38860","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38896","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-39659","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"langchain Code Injection vulnerability","id":"CVE-2023-36095","kev_date_added":null,"published":"2023-08-05"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36188","kev_date_added":null,"published":"2023-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via crafted input in the JiraAPIWrapper component of the Langchain library.","url":"https://insights.sbomify.com/CVE-2023-34540/"}