CVE-2023-34541 Langchain vulnerable to arbitrary code execution

Critical 9.8 Published Updated

Attackers can execute arbitrary code via the load_prompt function in the Langchain library, requiring developers to upgrade to a patched version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-34541?

CVE-2023-34541 is a critical code injection vulnerability in n/a, published on 20 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

Which versions are affected by CVE-2023-34541?

3 open source packages ship an affected version, including langchain. It affects 1 product.

PackageAffectedFixed in
langchain PyPIAll versions0.0.247
langchain PyPIAll versions0.0.247
langchain PyPIAll versions0.0.247

Products include Langchain Langchain.

How do I fix CVE-2023-34541?

Upgrade langchain to 0.0.247 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2023-34541 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34541 exists.

Sources

Also known as GHSA-6643-h7h5-x9wh, PYSEC-2023-92.

Is CVE-2023-34541 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free