# CVE-2023-34603: JeecgBoot vulnerable to SQL injection in queryFilterTableDictInfo

> SQL injection in JeecgBoot allows attackers to read or modify database data via the queryFilterTableDictInfo component.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2023
- **Updated:** 11 Dec 2024
- **Also known as:** GHSA-cvgc-465m-cw9g

## What is CVE-2023-34603?

CVE-2023-34603 is a high-severity SQL injection vulnerability in n/a, published on 19 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JeecgBoot up to v 3.5.1 was discovered to contain a SQL injection vulnerability via the component queryFilterTableDictInfo at org.jeecg.modules.api.controller.SystemApiController.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-34603?

2 open source packages ship an affected version, including org.jeecgframework.boot:jeecg-boot-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jeecgframework.boot:jeecg-boot-parent` | Maven | All versions | 3.5.1 |
| `org.jeecgframework.boot:jeecg-boot-parent` | Maven | All versions | 3.5.1 |

Products: Jeecg Jeecgboot.

## How do I fix CVE-2023-34603?

Upgrade org.jeecgframework.boot:jeecg-boot-parent to 3.5.1 or later.

## Is CVE-2023-34603 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34603 exists.

## Other vulnerabilities in n/a

- [CVE-2023-34602](https://insights.sbomify.com/CVE-2023-34602/): JeecgBoot vulnerable to SQL injection in queryTableDictItemsByCode (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34603 and fix it if it is affected.

What it is: CVE-2023-34603 is a high-severity SQL injection vulnerability in n/a, published on 19 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34603 exists.

Affected packages and fixed versions:
- org.jeecgframework.boot:jeecg-boot-parent (Maven): affected all versions; fixed in 3.5.1
- org.jeecgframework.boot:jeecg-boot-parent (Maven): affected all versions; fixed in 3.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34603/ (Markdown: https://insights.sbomify.com/CVE-2023-34603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34603
- OSV: https://osv.dev/vulnerability/CVE-2023-34603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34603/
Summaries are generated and may contain mistakes; the official description above is the record.
