# CVE-2023-34610: json-io vulnerable to stack exhaustion

> Attackers can cause denial of service in json-io library by sending crafted objects with cyclic dependencies.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2023
- **Updated:** 6 Jan 2025
- **Also known as:** CLSA-2026-1774398090, GHSA-779h-3r69-4f5p

## What is CVE-2023-34610?

CVE-2023-34610 is a high-severity denial of service vulnerability in n/a, published on 14 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered json-io thru 4.14.0 allows attackers to cause a denial of service or other unspecified impacts via crafted object that uses cyclic dependencies.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2023-34610?

2 open source packages ship an affected version, including com.cedarsoftware:json-io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.cedarsoftware:json-io` | Maven | All versions | 4.14.1 |
| `com.cedarsoftware:json-io` | Maven | All versions | 4.14.1 |

Products: Json-Io Project Json-Io.

## How do I fix CVE-2023-34610?

Upgrade com.cedarsoftware:json-io to 4.14.1 or later.

## Is CVE-2023-34610 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34610 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-34610 and fix it if it is affected.

What it is: CVE-2023-34610 is a high-severity denial of service vulnerability in n/a, published on 14 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-34610 exists.

Affected packages and fixed versions:
- com.cedarsoftware:json-io (Maven): affected all versions; fixed in 4.14.1
- com.cedarsoftware:json-io (Maven): affected all versions; fixed in 4.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-34610/ (Markdown: https://insights.sbomify.com/CVE-2023-34610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-34610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-34610
- OSV: https://osv.dev/vulnerability/CVE-2023-34610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-34610/
Summaries are generated and may contain mistakes; the official description above is the record.
