# CVE-2023-3481: XSS in Chrome Lab Critters


- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Aug 2023
- **Updated:** 27 Sep 2024
- **Also known as:** CLSA-2026-1792583825, GHSA-cx3j-qqxj-9597

## What is CVE-2023-3481?

CVE-2023-3481 is a medium-severity vulnerability in Google Chrome Labs Critters, published on 21 Aug 2023. 

### Official description

Critters versions 0.0.17-0.0.19 have an issue when parsing the HTML, which leads to a potential cross-site scripting (XSS) bug. We recommend upgrading to version 0.0.20 of the extension.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2023-3481?

2 open source packages ship an affected version, including critters. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `critters` | npm | From 0.0.17 | 0.0.20 |
| `critters` | npm | From 0.0.17 | 0.0.20 |

Products: Google Critters.

## How do I fix CVE-2023-3481?

Upgrade critters to 0.0.20 or later.

## Is CVE-2023-3481 being exploited?

There is no known exploitation of CVE-2023-3481 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3481 and fix it if it is affected.

What it is: CVE-2023-3481 is a medium-severity vulnerability in Google Chrome Labs Critters, published on 21 Aug 2023. 
Exploitation: There is no known exploitation of CVE-2023-3481 in the wild and no public exploit code.

Affected packages and fixed versions:
- critters (npm): affected from 0.0.17; fixed in 0.0.20
- critters (npm): affected from 0.0.17; fixed in 0.0.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3481/ (Markdown: https://insights.sbomify.com/CVE-2023-3481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3481
- OSV: https://osv.dev/vulnerability/CVE-2023-3481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3481/
Summaries are generated and may contain mistakes; the official description above is the record.
