CVE-2023-3484 Incorrect Authorization in GitLab

High 8.0 Published Updated

An attacker can modify the name or path of a public top-level group in GitLab EE due to incorrect authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-3484?

CVE-2023-3484 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 21 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 12.8 before 15.11.11, all versions starting from 16.0 before 16.0.7, all versions starting from 16.1 before 16.1.2. An attacker could change the name or path of a public top-level group in certain situations.

Weakness: CWE-863

Which versions are affected by CVE-2023-3484?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.8.015.11.11, 16.0.7, 16.1.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-3484?

Upgrade gitlab to a fixed version for your release line: 15.11.11, 16.0.7 or 16.1.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-3484 being exploited?

There is no known exploitation of CVE-2023-3484 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-3484, GHSA-gqgg-x9fc-fq5c.

Is CVE-2023-3484 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free